summaryrefslogtreecommitdiffstats
path: root/src/loader/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2018-11-15 13:54:49 -0800
committerEric Anholt <[email protected]>2018-11-16 17:49:17 -0800
commitd971a4230d54069c996bca78b6ed6a6a23377821 (patch)
tree2d9c29c0c0df5405a0bad5b2c7860bcc614069a2 /src/loader/meson.build
parentcc198157382a988590b0288d287281139c5f73e6 (diff)
loader: Factor out the common driver opening logic from each loader.
I copied the code from egl_dri2.c, but the functionality was equivalent between all the loaders other than their particular environment variables. v2: Drop the logging function equivalent to loader_default_logger() (requested by Eric, Emil). Move the SCons workaround across. Drop the now-unused driGetDriverExtensions() declaration that was lost in a rebase. Reviewed-by: Eric Engestrom <[email protected]> (v1) Reviewed-by: Emil Velikov <[email protected]> (v1)
Diffstat (limited to 'src/loader/meson.build')
-rw-r--r--src/loader/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/loader/meson.build b/src/loader/meson.build
index 76fcae2cb44..e280ba41cc2 100644
--- a/src/loader/meson.build
+++ b/src/loader/meson.build
@@ -39,7 +39,9 @@ libloader = static_library(
'loader',
['loader.c', 'loader.h', 'pci_id_driver_map.c', 'pci_id_driver_map.h',
xmlpool_options_h],
- c_args : [c_vis_args, '-DUSE_DRICONF'],
+ c_args : [c_vis_args, '-DUSE_DRICONF',
+ '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
+],
include_directories : [inc_include, inc_src, inc_util],
dependencies : [dep_libdrm, dep_thread],
build_by_default : false,