summaryrefslogtreecommitdiffstats
path: root/src/loader/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2018-11-15 13:54:49 -0800
committerEric Anholt <[email protected]>2018-11-16 17:49:17 -0800
commitd971a4230d54069c996bca78b6ed6a6a23377821 (patch)
tree2d9c29c0c0df5405a0bad5b2c7860bcc614069a2 /src/loader/Makefile.am
parentcc198157382a988590b0288d287281139c5f73e6 (diff)
loader: Factor out the common driver opening logic from each loader.
I copied the code from egl_dri2.c, but the functionality was equivalent between all the loaders other than their particular environment variables. v2: Drop the logging function equivalent to loader_default_logger() (requested by Eric, Emil). Move the SCons workaround across. Drop the now-unused driGetDriverExtensions() declaration that was lost in a rebase. Reviewed-by: Eric Engestrom <[email protected]> (v1) Reviewed-by: Emil Velikov <[email protected]> (v1)
Diffstat (limited to 'src/loader/Makefile.am')
-rw-r--r--src/loader/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/loader/Makefile.am b/src/loader/Makefile.am
index 76252564281..3c22e0ae7e6 100644
--- a/src/loader/Makefile.am
+++ b/src/loader/Makefile.am
@@ -28,6 +28,7 @@ noinst_LTLIBRARIES = libloader.la
AM_CPPFLAGS = \
-I$(top_builddir)/src/util/ \
-DUSE_DRICONF \
+ -DDEFAULT_DRIVER_DIR=\"$(DRI_DRIVER_SEARCH_DIR)\" \
$(DEFINES) \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/drm-uapi \