summaryrefslogtreecommitdiffstats
path: root/src/loader/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-01-10 23:36:16 +0000
committerEmil Velikov <[email protected]>2014-01-18 18:47:27 +0000
commit8c2e7fd8460750543367053b1be9368cc38e1d6a (patch)
tree9587b089f9e43b090a8104661a1c5e27f0769a08 /src/loader/Makefile.am
parent1c5e2965a0de296240dd8f5af12482164416b7f1 (diff)
loader: introduce the loader util lib
All the various window system integration layers duplicate roughly the same code for figuring out device and driver name, pci-id's, etc. Which is sad. So extract it out into a loader util lib. v2 (Emil) * Separate the introduction of libloader from the code de-duplication. * Strip out non-pci devices support. * Add scons + Android build system support. * Add VISIBILITY_CFLAGS to avoid exporting the loader funcs. v3 (Emil) * PIPE_OS_ANDROID is undefined at this scope, use ANDROID * Make sure we define _EGL_NO_DRM when building only swrast Signed-off-by: Rob Clark <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Rob Clark <[email protected]> Reviewed-by: Kristian Høgsberg <[email protected]> Reviewed-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/loader/Makefile.am')
-rw-r--r--src/loader/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/loader/Makefile.am b/src/loader/Makefile.am
new file mode 100644
index 00000000000..a118fef1d9c
--- /dev/null
+++ b/src/loader/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+include Makefile.sources
+
+noinst_LTLIBRARIES = libloader.la
+
+libloader_la_CPPFLAGS = \
+ $(DEFINES) \
+ -I$(top_srcdir)/include \
+ $(VISIBILITY_CFLAGS) \
+ $(LIBDRM_CFLAGS) \
+ $(LIBUDEV_CFLAGS)
+
+libloader_la_LIBADD = \
+ $(LIBDRM_LIBS) \
+ $(LIBUDEV_LIBS)
+
+libloader_la_SOURCES = $(LOADER_C_FILES)