summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <[email protected]>2017-06-19 16:56:47 +0100
committerLionel Landwerlin <[email protected]>2017-10-06 16:32:19 +0100
commitf3e91e78a3377594f0ef40ba50abed04dc590623 (patch)
tree39d77695e5f60bc9c38177da50282a3547107cf6 /src/intel/vulkan/meson.build
parent3492d560671c09a4d42630cbf51ceaefc99b9db6 (diff)
anv: add nir lowering pass for ycbcr textures
This pass implements all the implicit conversions required by the VK_KHR_sampler_ycbcr_conversion specification. It also inserts plane sources onto sampling instructions that we then let the pipeline layout pass deal with, when mapping things correctly to descriptors. v2: Add new file to meson build (Lionel) Use nir_frcp() rather than (1.0f / x) (Jason) Reuse nir_tex_instr_dest_size() rather than handwritten one (Jason) Return progress (Jason) Account for array of samplers (Jason) Signed-off-by: Lionel Landwerlin <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index 6ce092e05ce..ff24e304ef5 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -101,6 +101,7 @@ libanv_files = files(
'anv_nir_lower_input_attachments.c',
'anv_nir_lower_multiview.c',
'anv_nir_lower_push_constants.c',
+ 'anv_nir_lower_ycbcr_textures.c',
'anv_pass.c',
'anv_pipeline.c',
'anv_pipeline_cache.c',