summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-01-23 09:37:03 -0800
committerDylan Baker <[email protected]>2018-02-15 09:45:56 -0800
commitb03969a5adeffaceec7ff722e90205c4284b1f1e (patch)
tree55a532105037b99b2e98fce64dd8dc91db24ca5d /src/intel/vulkan/meson.build
parent384bff13e034bcca06eec1bdf50a3913f9e941db (diff)
meson: use depend_files to track extra file dependencies
cc: Jason Ekstrand <[email protected]> Fixes: f93994080993bda ("anv: Split anv_extensions.py into two files") Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Samuel Iglesias Gonsálvez <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index d0712f318c7..3f1a2de9fd3 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -31,13 +31,13 @@ anv_entrypoints = custom_target(
anv_extensions_c = custom_target(
'anv_extensions.c',
- input : ['anv_extensions_gen.py', vk_api_xml, vk_android_native_buffer_xml,
- 'anv_extensions.py'],
+ input : ['anv_extensions_gen.py', vk_api_xml, vk_android_native_buffer_xml],
output : 'anv_extensions.c',
command : [
prog_python2, '@INPUT0@', '--xml', '@INPUT1@', '--xml', '@INPUT2@',
'--out-c', '@OUTPUT@',
],
+ depend_files : files('anv_extensions.py'),
)
anv_extensions_h = custom_target(