summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-12-11 16:13:31 -0800
committerDylan Baker <[email protected]>2018-01-11 15:40:02 -0800
commit4ccb9816737945159289527322e759d92bf7a4d6 (patch)
tree5f4cc22fa3d962cfde826599e5a95e26904bdc8d /src/intel/vulkan/meson.build
parent8e981eb2b7099849c7b74d855afb0c65f92227e8 (diff)
meson: Use consistent style for tests
Don't use intermediate variables, use consistent whitespace. Acked-by: Eric Engestrom <[email protected]> Signed-off-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build23
1 files changed, 13 insertions, 10 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index b219201944b..66266a0e95a 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -193,25 +193,28 @@ if with_tests
link_whole : libanv_common,
link_with : [
libanv_gen_libs, libintel_compiler, libintel_common, libisl, libblorp,
- libvulkan_util, libvulkan_wsi, libnir, libmesa_util,
+ libvulkan_util, libvulkan_wsi, libmesa_util,
],
dependencies : [
dep_libdrm, dep_thread, dep_dl, dep_m, anv_deps, dep_valgrind,
+ idep_nir,
],
c_args : [c_vis_args, no_override_init_args, '-msse2', anv_flags],
)
foreach t : ['block_pool_no_free', 'state_pool_no_free',
'state_pool_free_list_only', 'state_pool']
- _exe = executable(
- t,
- ['tests/@[email protected]'.format(t), dummy_cpp, block_entrypoints],
- link_with : libvulkan_intel_test,
- dependencies : [dep_libdrm, dep_thread, dep_m, dep_valgrind],
- include_directories : [
- inc_common, inc_intel, inc_compiler, inc_vulkan_util, inc_vulkan_wsi,
- ],
+ test(
+ 'anv_@0@'.format(t),
+ executable(
+ t,
+ ['tests/@[email protected]'.format(t), dummy_cpp, block_entrypoints],
+ link_with : libvulkan_intel_test,
+ dependencies : [dep_libdrm, dep_thread, dep_m, dep_valgrind],
+ include_directories : [
+ inc_common, inc_intel, inc_compiler, inc_vulkan_util, inc_vulkan_wsi,
+ ],
+ )
)
- test('anv_@0@'.format(t), _exe)
endforeach
endif