summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorKeith Packard <[email protected]>2018-02-09 07:45:58 -0800
committerKeith Packard <[email protected]>2018-06-19 14:17:46 -0700
commit46090a642d54d58bbdb851ae62beb5c350101324 (patch)
treef96ff23010d1fefa7f8b67b6fe56812993345ee0 /src/intel/vulkan/meson.build
parent7ab1fffcd2a504024b16e408de329f7a94553ecc (diff)
anv: Add EXT_acquire_xlib_display to anv driver [v3]
This extension adds the ability to borrow an X RandR output for temporary use directly by a Vulkan application to the anv driver. v2: Simplify addition of VK_USE_PLATFORM_XLIB_XRANDR_KHR to vulkan_wsi_args Suggested-by: Eric Engestrom <[email protected]> v3: Add extension to list in alphabetical order Suggested-by: Jason Ekstrand <[email protected]> Signed-off-by: Keith Packard <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index 797473500ff..4b0652f757b 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -169,6 +169,11 @@ if with_platform_drm
libanv_files += files('anv_wsi_display.c')
endif
+if with_xlib_lease
+ anv_deps += dep_xcb_xrandr
+ anv_flags += '-DVK_USE_PLATFORM_XLIB_XRANDR_EXT'
+endif
+
libanv_common = static_library(
'anv_common',
[libanv_files, anv_entrypoints, anv_extensions_c, anv_extensions_h],