summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorJordan Justen <[email protected]>2018-02-26 15:39:59 -0800
committerJordan Justen <[email protected]>2018-03-05 09:47:37 -0800
commit272bef0601a1bdb5292771aefc8d62fcbdf4c47f (patch)
treec94ae513a916ed81151067da24260bbb424e5deb /src/intel/vulkan/meson.build
parent9a0d7bb48c93e7d0109751469a8b32c94e85bc24 (diff)
intel: Split gen_device_info out into libintel_dev
Split out the device info so isl doesn't depend on intel/common. Now it will depend on the new intel/dev device info lib. This will allow the decoder in intel/common to use isl, allowing us to apply Ken's patch that removes the genxml duplication of surface formats. Signed-off-by: Jordan Justen <[email protected]> Reviewed-by: Samuel Iglesias Gonsálvez <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index f0317236702..d45331febe0 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -192,8 +192,8 @@ libvulkan_intel = shared_library(
],
link_whole : [libanv_common, libanv_gen_libs],
link_with : [
- libintel_compiler, libintel_common, libisl, libblorp, libvulkan_util,
- libvulkan_wsi, libmesa_util,
+ libintel_compiler, libintel_common, libintel_dev, libisl, libblorp,
+ libvulkan_util, libvulkan_wsi, libmesa_util,
],
dependencies : [
dep_thread, dep_dl, dep_m, anv_deps, idep_nir,
@@ -213,8 +213,8 @@ if with_tests
],
link_whole : libanv_common,
link_with : [
- libanv_gen_libs, libintel_compiler, libintel_common, libisl, libblorp,
- libvulkan_util, libvulkan_wsi, libmesa_util,
+ libanv_gen_libs, libintel_compiler, libintel_common, libintel_dev,
+ libisl, libblorp, libvulkan_util, libvulkan_wsi, libmesa_util,
],
dependencies : [
dep_thread, dep_dl, dep_m, anv_deps, idep_nir,