summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <[email protected]>2018-08-09 10:27:26 +0200
committerDylan Baker <[email protected]>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /src/intel/vulkan/meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index e427c7471f4..e11bcb0c695 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -25,7 +25,7 @@ anv_entrypoints = custom_target(
input : ['anv_entrypoints_gen.py', vk_api_xml],
output : ['anv_entrypoints.h', 'anv_entrypoints.c'],
command : [
- prog_python2, '@INPUT0@', '--xml', '@INPUT1@',
+ prog_python, '@INPUT0@', '--xml', '@INPUT1@',
'--outdir', meson.current_build_dir(),
],
depend_files : anv_extensions_py,
@@ -36,7 +36,7 @@ anv_extensions_c = custom_target(
input : ['anv_extensions_gen.py', vk_api_xml],
output : 'anv_extensions.c',
command : [
- prog_python2, '@INPUT0@', '--xml', '@INPUT1@',
+ prog_python, '@INPUT0@', '--xml', '@INPUT1@',
'--out-c', '@OUTPUT@',
],
depend_files : anv_extensions_py,
@@ -47,7 +47,7 @@ anv_extensions_h = custom_target(
input : ['anv_extensions_gen.py', vk_api_xml],
output : 'anv_extensions.h',
command : [
- prog_python2, '@INPUT0@', '--xml', '@INPUT1@',
+ prog_python, '@INPUT0@', '--xml', '@INPUT1@',
'--out-h', '@OUTPUT@',
],
depend_files : anv_extensions_py,
@@ -58,7 +58,7 @@ intel_icd = custom_target(
input : 'anv_icd.py',
output : 'intel_icd.@[email protected]'.format(host_machine.cpu()),
command : [
- prog_python2, '@INPUT@',
+ prog_python, '@INPUT@',
'--lib-path', join_paths(get_option('prefix'), get_option('libdir')),
'--out', '@OUTPUT@',
],
@@ -73,7 +73,7 @@ dev_icd = custom_target(
input : 'anv_icd.py',
output : 'dev_icd.@[email protected]'.format(host_machine.cpu()),
command : [
- prog_python2, '@INPUT@', '--lib-path', meson.current_build_dir(),
+ prog_python, '@INPUT@', '--lib-path', meson.current_build_dir(),
'--out', '@OUTPUT@'
],
depend_files : files('anv_extensions.py'),