summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
authorSergii Romantsov <[email protected]>2018-09-06 11:07:45 +0300
committerLionel Landwerlin <[email protected]>2018-09-07 13:45:46 +0100
commitd709f127927cb0ad40d5bf4eaec33c3c27f7738a (patch)
treecf322d59e14b46e9fbae1add8a68d02c5de3b029 /src/intel/vulkan/meson.build
parent5404e0637f17fa7ae33db33760e10bf4f73b3095 (diff)
intel: compiler option msse2 and mstackrealign
Seems in case of 32-bit library, usage of msse2 makes some stack corruption or incorrect instructions. Usage with mstackrealign fixes that case. v2: Fixed meson. v3: Definition of c_sse2_args moved on the top (L.Landwerlin). Added mstackrealign for Android's mks where msee4.1 is used. v4: Added for Vulkan also. v5: Commit message correction. CC: <[email protected]> Fixes: 6b05c080f202 (i965: Compile with -msse3) Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=107779 Signed-off-by: Sergii Romantsov <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Lionel Landwerlin <[email protected]>
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index e11bcb0c695..f1beb1de6ac 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -102,7 +102,7 @@ foreach g : [['70', ['gen7_cmd_buffer.c']], ['75', ['gen7_cmd_buffer.c']],
inc_vulkan_wsi,
],
c_args : [
- c_vis_args, no_override_init_args, '-msse2',
+ c_vis_args, no_override_init_args, c_sse2_args,
'-DGEN_VERSIONx10=@0@'.format(_gen),
],
dependencies : [dep_libdrm, dep_valgrind, idep_nir_headers],
@@ -146,7 +146,7 @@ anv_deps = [
anv_flags = [
c_vis_args,
no_override_init_args,
- '-msse2',
+ c_sse2_args,
]
if with_platform_x11