summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-05-27 15:35:38 +0100
committerEmil Velikov <[email protected]>2016-05-30 10:28:56 +0100
commit220d8c99fa5c0f38371fb7cf11251de3e54ae2c0 (patch)
treea29e35ab59f2465de875d4697af9c6f8f0348530 /src/intel/vulkan/Makefile.am
parent82514f26d83eec9771790c74a0b4901947f5ec41 (diff)
anv: automake: bring back VULKAN_ENTRYPOINT_CPPFLAGS
We should not have removed them in the first place. There's a subtle difference between generating the complete sources and using them which was not obvious as we nuked them. Without this, the release tarball ends up without various hunks of the generated sources, thus things fail at a later stage as we attempt to build them. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/intel/vulkan/Makefile.am')
-rw-r--r--src/intel/vulkan/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/intel/vulkan/Makefile.am b/src/intel/vulkan/Makefile.am
index d59d8565048..cbbb9ed9e29 100644
--- a/src/intel/vulkan/Makefile.am
+++ b/src/intel/vulkan/Makefile.am
@@ -124,12 +124,16 @@ VULKAN_LIB_DEPS += \
nodist_EXTRA_libvulkan_intel_la_SOURCES = dummy.cpp
libvulkan_intel_la_SOURCES = $(VULKAN_GEM_FILES)
+VULKAN_ENTRYPOINT_CPPFLAGS = \
+ -DVK_USE_PLATFORM_XCB_KHR \
+ -DVK_USE_PLATFORM_WAYLAND_KHR
+
anv_entrypoints.h : anv_entrypoints_gen.py $(vulkan_include_HEADERS)
- $(AM_V_GEN)$(CPP) $(AM_CPPFLAGS) $(top_srcdir)/include/vulkan/vulkan_intel.h |\
+ $(AM_V_GEN)$(CPP) $(VULKAN_ENTRYPOINT_CPPFLAGS) $(top_srcdir)/include/vulkan/vulkan_intel.h |\
$(PYTHON2) $(srcdir)/anv_entrypoints_gen.py header > $@
anv_entrypoints.c : anv_entrypoints_gen.py $(vulkan_include_HEADERS)
- $(AM_V_GEN)$(CPP) $(AM_CPPFLAGS) $(top_srcdir)/include/vulkan/vulkan_intel.h |\
+ $(AM_V_GEN)$(CPP) $(VULKAN_ENTRYPOINT_CPPFLAGS) $(top_srcdir)/include/vulkan/vulkan_intel.h |\
$(PYTHON2) $(srcdir)/anv_entrypoints_gen.py code > $@
BUILT_SOURCES = $(VULKAN_GENERATED_FILES)