summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-02-15 15:41:50 -0800
committerDylan Baker <[email protected]>2017-02-22 13:12:02 -0800
commite9dcb17962f7e58a81c93bae7bd33885675b1043 (patch)
tree55332d8cdb6783ab65fc8d34e4df8168fb38dcab /src/intel/vulkan/Makefile.am
parentbda59f6e417b68985ffc8dbb92fcfe19ba12f7bf (diff)
vulkan/util: Add generator for enum_to_str functions
This adds a python generator to produce enum_to_str functions for Vulkan from the vk.xml API description. It supports extensions as well as core API features, and the generator works with both python2 and python3. Signed-off-by: Dylan Baker <[email protected]> Acked-by: Matt Turner <[email protected]> Acked-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/intel/vulkan/Makefile.am')
-rw-r--r--src/intel/vulkan/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/intel/vulkan/Makefile.am b/src/intel/vulkan/Makefile.am
index 93f2ceb00f1..b9b79f44055 100644
--- a/src/intel/vulkan/Makefile.am
+++ b/src/intel/vulkan/Makefile.am
@@ -49,6 +49,7 @@ AM_CPPFLAGS = \
-I$(top_builddir)/src \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/vulkan/wsi \
+ -I$(top_builddir)/src/vulkan/util \
-I$(top_builddir)/src/compiler \
-I$(top_srcdir)/src/compiler \
-I$(top_builddir)/src/compiler/nir \
@@ -126,6 +127,7 @@ libvulkan_common_la_SOURCES = $(VULKAN_SOURCES)
VULKAN_LIB_DEPS += \
libvulkan_common.la \
+ $(top_builddir)/src/vulkan/util/libvulkan_util.la \
$(top_builddir)/src/vulkan/wsi/libvulkan_wsi.la \
$(top_builddir)/src/mesa/drivers/dri/i965/libi965_compiler.la \
$(top_builddir)/src/compiler/nir/libnir.la \