summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2017-02-14 08:21:43 -0800
committerMatt Turner <[email protected]>2017-02-15 13:59:51 -0800
commit656e30b6860461b2bd725590488126d5e7e10ec1 (patch)
tree5b331637303f495d07dee423700eabb0a9c96dca /src/intel/vulkan/Makefile.am
parentd4fa083e11fa71abd50e615d6f02b6da4ea34644 (diff)
anv: Use build-id for pipeline cache UUID.
The --build-id=... ld flag has been present since binutils-2.18, released 28 Aug 2007. Reviewed-by: Jason Ekstrand <[email protected]> Reviewed-by: Chad Versace <[email protected]>
Diffstat (limited to 'src/intel/vulkan/Makefile.am')
-rw-r--r--src/intel/vulkan/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/intel/vulkan/Makefile.am b/src/intel/vulkan/Makefile.am
index 95f276ed7e1..4197b0e77c7 100644
--- a/src/intel/vulkan/Makefile.am
+++ b/src/intel/vulkan/Makefile.am
@@ -165,6 +165,7 @@ libvulkan_intel_la_LDFLAGS = \
-module \
-no-undefined \
-avoid-version \
+ -Wl,--build-id=sha1 \
$(BSYMBOLIC) \
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)