summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-07-06 16:18:21 +0100
committerMark Janes <[email protected]>2016-07-06 10:19:19 -0700
commit9618e2a24c18b5bbc9ff872d1f6870261d14dee5 (patch)
treedf94a809990c8a152bafd7784da8fad8d6d08870 /src/intel/vulkan/Makefile.am
parent64d35f817afc3106684dd74491b14be4d676cb88 (diff)
anv: vulkan: remove the anv_device.$(OBJEXT) rule
Atm the actual rule will expand to foo.o which is used for static libraries only. Thus the automake manual recommendation [to use OBJEXT] won't help us, since since we're working with a shared library. Thus let's 'demote' the file and add it back to BUILT_SOURCES. This will manage all the complexity for us, at the (existing expense) of working only with the all, check and install targets. The crazy (why the issue was hard to spot): If the dependencies (.deps/*.Plo) are already created one can alter the anv_device.$(OBJEXT) line and/or nuke it all together. That won't lead to any warnings/issues, even though the Makefile is regenerated. Moral of the story: Always rm -rf top_builddir or don't resolve the dependencies manually and use BUILT_SOURCES. Cc: "12.0" <[email protected]> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=96825 Fixes: d7a604c3f7a ("anv: use cache uuid based on the build timestamp.") Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]> Tested-by: Mark Janes <[email protected]>
Diffstat (limited to 'src/intel/vulkan/Makefile.am')
-rw-r--r--src/intel/vulkan/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/intel/vulkan/Makefile.am b/src/intel/vulkan/Makefile.am
index 07c81a89af4..fe7371e9665 100644
--- a/src/intel/vulkan/Makefile.am
+++ b/src/intel/vulkan/Makefile.am
@@ -137,10 +137,8 @@ anv_timestamp.h:
@echo "Updating anv_timestamp.h"
$(AM_V_GEN) echo "#define ANV_TIMESTAMP \"$(TIMESTAMP_CMD)\"" > $@
-anv_device.$(OBJEXT): anv_timestamp.h
-
BUILT_SOURCES = $(VULKAN_GENERATED_FILES)
-CLEANFILES = $(BUILT_SOURCES) dev_icd.json anv_timestamp.h
+CLEANFILES = $(BUILT_SOURCES) dev_icd.json
EXTRA_DIST = \
$(top_srcdir)/include/vulkan/vk_icd.h \
anv_entrypoints_gen.py \