summaryrefslogtreecommitdiffstats
path: root/src/intel/tools/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <[email protected]>2018-07-29 19:32:45 +0100
committerLionel Landwerlin <[email protected]>2018-08-22 18:02:11 +0100
commitea83a1d304dc97d1d155a633e95d902a08703175 (patch)
tree98905650fea93c824f2c4b011f52767919af7226 /src/intel/tools/meson.build
parent4ba12e8c54d530a0034ba714bb0b95dbf3940b40 (diff)
intel: tools: import ImGui
We want to add a new UI tool to decode aub files. This will use the Dear ImGui library to render its interface. The build of this UI toolkit is conditional to -Dwith_tools=intel-ui which superseeds -Dwith_tools=intel. The main way to use ImGui is to embed its source code at a particular revision. Most embedding projects have to do a bit of integration which is really specific to one's project. In our case the only modification is to include libepoxy. We also choose to use Gtk+3 for the window system integration. As oppose to the previous previous version of this patch using GLFW, Gtk+ is able to handle X11/Wayland session as well as property DPI scaling on retina monitors. The import was done at this commit (https://github.com/ocornut/imgui) : commit 6211f40f3d903dd9df961256e044029c49793aa3 Author: omar <[email protected]> Date: Fri Jul 27 12:29:33 2018 +0200 Internals: Drag and Drop: default drop preview use a narrower clipping rectangle (no effect here, but other branches uses a narrow clipping rectangle that was too small so this is a fix for it) + Comments v2: Switch from GLFW to GTK+ (Lionel) Signed-off-by: Lionel Landwerlin <[email protected]> Acked-by: Rafael Antognolli <[email protected]>
Diffstat (limited to 'src/intel/tools/meson.build')
-rw-r--r--src/intel/tools/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/intel/tools/meson.build b/src/intel/tools/meson.build
index 258bf7011b3..396c19ecfaa 100644
--- a/src/intel/tools/meson.build
+++ b/src/intel/tools/meson.build
@@ -18,7 +18,6 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
-
libaub = static_library(
'aub',
files('aub_read.c', 'aub_mem.c'),
@@ -106,3 +105,7 @@ libintel_dump_gpu = shared_library(
install_dir: get_option('libexecdir'),
install: true
)
+
+if with_tools.contains('intel-ui')
+ subdir('imgui')
+endif