summaryrefslogtreecommitdiffstats
path: root/src/intel/tools/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <[email protected]>2018-02-07 16:55:24 -0800
committerScott D Phillips <[email protected]>2018-02-08 11:24:42 -0800
commit1f4d2433e73a0a6d4e2a180de407970d983309db (patch)
treeee69bacbb0af123566f2d2c4320127626cd5cca9 /src/intel/tools/meson.build
parent464d057c86ab36db81590aa940902ff7e29894da (diff)
meson: Add build option for tools
Add a build option to control building some of the misc tools we have. Also set the executables to install, presumably you want that if you're asking for the build. v2: set 'install:' to the with_tools value, not true (Jordan) handle 'all' in a the comma list (Dylan) Add freedreno's tools (Dylan) Reviewed-by: Eric Anholt <[email protected]> Reviewed-by: Jordan Justen <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/intel/tools/meson.build')
-rw-r--r--src/intel/tools/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/intel/tools/meson.build b/src/intel/tools/meson.build
index 7890eeca1dc..82413041b13 100644
--- a/src/intel/tools/meson.build
+++ b/src/intel/tools/meson.build
@@ -26,7 +26,8 @@ aubinator = executable(
include_directories : [inc_common, inc_intel],
link_with : [libintel_common, libintel_compiler, libmesa_util],
c_args : [c_vis_args, no_override_init_args],
- build_by_default : false,
+ build_by_default : with_tools.contains('intel'),
+ install : with_tools.contains('intel'),
)
aubinator_error_decode = executable(
@@ -37,5 +38,6 @@ aubinator_error_decode = executable(
include_directories : [inc_common, inc_intel],
link_with : [libintel_common, libintel_compiler, libmesa_util],
c_args : [c_vis_args, no_override_init_args],
- build_by_default : false,
+ build_by_default : with_tools.contains('intel'),
+ install : with_tools.contains('intel'),
)