summaryrefslogtreecommitdiffstats
path: root/src/intel/tools/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <[email protected]>2018-07-28 13:52:44 +0100
committerLionel Landwerlin <[email protected]>2018-08-01 15:31:56 +0100
commit2477e516d943bd7439b8073bb15eb1ede7ea74b9 (patch)
tree1961ea933a83095fac3f3395dacfd21504f7d556 /src/intel/tools/meson.build
parent91939255a7c556a5d85a57fb6a191e0c8cfd29ce (diff)
intel: tools: aubwrite: split gen[89] from gen10+
Gen10+ has an additional bit in MI_BATCH_BUFFER_END to signal the end of the context image. We select the largest size for the context image regardless of the generation. Signed-off-by: Lionel Landwerlin <[email protected]> Reviewed-by: Rafael Antognolli <[email protected]>
Diffstat (limited to 'src/intel/tools/meson.build')
-rw-r--r--src/intel/tools/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/intel/tools/meson.build b/src/intel/tools/meson.build
index 7c6d4831fe0..37bc04d8301 100644
--- a/src/intel/tools/meson.build
+++ b/src/intel/tools/meson.build
@@ -84,7 +84,8 @@ if with_tools.contains('intel')
libintel_dump_gpu = shared_library(
'intel_dump_gpu',
- files('aub_write.h', 'aub_write.c', 'intel_dump_gpu.c'),
+ files('gen_context.h', 'gen8_context.h', 'gen10_context.h',
+ 'intel_aub.h', 'aub_write.h', 'aub_write.c', 'intel_dump_gpu.c'),
dependencies : dep_dl,
include_directories : [inc_common, inc_intel, inc_drm_uapi],
link_with : libintel_dev,