summaryrefslogtreecommitdiffstats
path: root/src/intel/isl/meson.build
diff options
context:
space:
mode:
authorJordan Justen <[email protected]>2018-02-26 15:39:59 -0800
committerJordan Justen <[email protected]>2018-03-05 09:47:37 -0800
commit272bef0601a1bdb5292771aefc8d62fcbdf4c47f (patch)
treec94ae513a916ed81151067da24260bbb424e5deb /src/intel/isl/meson.build
parent9a0d7bb48c93e7d0109751469a8b32c94e85bc24 (diff)
intel: Split gen_device_info out into libintel_dev
Split out the device info so isl doesn't depend on intel/common. Now it will depend on the new intel/dev device info lib. This will allow the decoder in intel/common to use isl, allowing us to apply Ken's patch that removes the genxml duplication of surface formats. Signed-off-by: Jordan Justen <[email protected]> Reviewed-by: Samuel Iglesias Gonsálvez <[email protected]>
Diffstat (limited to 'src/intel/isl/meson.build')
-rw-r--r--src/intel/isl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/intel/isl/meson.build b/src/intel/isl/meson.build
index 36b8b8ffa20..73a8837f2ad 100644
--- a/src/intel/isl/meson.build
+++ b/src/intel/isl/meson.build
@@ -95,7 +95,7 @@ if with_tests
'tests/isl_surf_get_image_offset_test.c',
dependencies : dep_m,
include_directories : [inc_common, inc_intel],
- link_with : [libisl, libintel_common],
+ link_with : [libisl, libintel_dev],
)
)
endif