summaryrefslogtreecommitdiffstats
path: root/src/intel/isl/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2016-06-13 11:19:18 -0700
committerJason Ekstrand <[email protected]>2016-06-13 22:40:52 -0700
commit5a87bc718197deab7577a028c64a7f591bbfaec4 (patch)
tree9b61da085cd037ef11363c13c92df901871f3058 /src/intel/isl/Makefile.am
parented2dae86aef759a6858f56d77eba77895bec5020 (diff)
isl: Replace bash generator with python generator
This replaces the current bash generator with a python based generator using mako. It's quite fast and works with both python 2.7 and python 3.5, and should work with 3.3+ and maybe even 3.2. It produces an almost identical file except for a minor layout changes, and the addition of a "generated file, do not edit" warning. Cc: "12.0" <[email protected]> Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/intel/isl/Makefile.am')
-rw-r--r--src/intel/isl/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/intel/isl/Makefile.am b/src/intel/isl/Makefile.am
index 74f863ab697..1fd668371d7 100644
--- a/src/intel/isl/Makefile.am
+++ b/src/intel/isl/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright 2015 Intel Corporation
+# Copyright 2015-2016 Intel Corporation
#
# Permission is hereby granted, free of charge, to any person obtaining a
# copy of this software and associated documentation files (the "Software"),
@@ -66,10 +66,12 @@ libisl_gen9_la_CFLAGS = $(libisl_la_CFLAGS) -DGEN_VERSIONx10=90
BUILT_SOURCES = $(ISL_GENERATED_FILES)
-isl_format_layout.c: isl_format_layout_gen.bash \
+PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
+
+isl_format_layout.c: gen_format_layout.py \
isl_format_layout.csv
- $(AM_V_GEN)$(srcdir)/isl_format_layout_gen.bash \
- <$(srcdir)/isl_format_layout.csv >$@
+ $(PYTHON_GEN) $(srcdir)/gen_format_layout.py \
+ --csv $(srcdir)/isl_format_layout.csv --out $@
# ----------------------------------------------------------------------------
# Tests
@@ -87,6 +89,6 @@ tests_isl_surf_get_image_offset_test_LDADD = \
# ----------------------------------------------------------------------------
EXTRA_DIST = \
- isl_format_layout_gen.bash \
+ gen_format_layout.py \
isl_format_layout.csv \
README