summaryrefslogtreecommitdiffstats
path: root/src/intel/compiler/meson.build
diff options
context:
space:
mode:
authorFrancisco Jerez <[email protected]>2016-03-06 18:11:20 -0800
committerMatt Turner <[email protected]>2020-03-06 10:20:30 -0800
commit03eb46f4a74c8df3de6785ffe18e968b876469b8 (patch)
treee908f4481001704941ea31565c2bcef00c891571 /src/intel/compiler/meson.build
parent27ae3c1f684fe64e47f7a6cd374dc156f15847e0 (diff)
intel/compiler: Introduce simple IR analysis pass framework
Motivated in detail in the source code. The only piece missing here from the analysis pass infrastructure is some sort of mechanism to broadcast changes in the IR to all existing analysis passes, which will be addressed by a future commit. The analysis_dependency_class enum might seem a bit silly at this point, more interesting dependency categories will be defined later on. Reviewed-by: Matt Turner <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4012>
Diffstat (limited to 'src/intel/compiler/meson.build')
-rw-r--r--src/intel/compiler/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/intel/compiler/meson.build b/src/intel/compiler/meson.build
index 2c44949c2b7..b110c0efeb3 100644
--- a/src/intel/compiler/meson.build
+++ b/src/intel/compiler/meson.build
@@ -70,6 +70,7 @@ libintel_compiler_files = files(
'brw_interpolation_map.c',
'brw_ir.h',
'brw_ir_allocator.h',
+ 'brw_ir_analysis.h',
'brw_ir_fs.h',
'brw_ir_vec4.h',
'brw_nir.h',