summaryrefslogtreecommitdiffstats
path: root/src/intel/compiler/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2017-10-06 10:08:11 -0700
committerJason Ekstrand <[email protected]>2017-10-12 22:39:30 -0700
commitb1d1b7222acfe45e447d1708d60b3ff98ca5a9a7 (patch)
treec6ecf720d2fb8a15238bb8f1e02596b5d2df1762 /src/intel/compiler/meson.build
parent2db9470d88bb4856152465f44fa090f1a1bbf039 (diff)
intel/compiler: Make brw_nir_lower_intrinsics compute-specific
It's already only ever called from brw_compile_cs and only handles compute intrinsics. Let's just make it CS-specific. We can always make it handle other stages again later if we want. Reviewed-by: Jordan Justen <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/intel/compiler/meson.build')
-rw-r--r--src/intel/compiler/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/intel/compiler/meson.build b/src/intel/compiler/meson.build
index 41c2f6ef1db..e29e1d39e2a 100644
--- a/src/intel/compiler/meson.build
+++ b/src/intel/compiler/meson.build
@@ -73,7 +73,7 @@ libintel_compiler_files = files(
'brw_nir_analyze_boolean_resolves.c',
'brw_nir_analyze_ubo_ranges.c',
'brw_nir_attribute_workarounds.c',
- 'brw_nir_intrinsics.c',
+ 'brw_nir_lower_cs_intrinsics.c',
'brw_nir_opt_peephole_ffma.c',
'brw_nir_tcs_workarounds.c',
'brw_packed_float.c',