summaryrefslogtreecommitdiffstats
path: root/src/intel/compiler/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-12-11 16:13:31 -0800
committerDylan Baker <[email protected]>2018-01-11 15:40:02 -0800
commit4ccb9816737945159289527322e759d92bf7a4d6 (patch)
tree5f4cc22fa3d962cfde826599e5a95e26904bdc8d /src/intel/compiler/meson.build
parent8e981eb2b7099849c7b74d855afb0c65f92227e8 (diff)
meson: Use consistent style for tests
Don't use intermediate variables, use consistent whitespace. Acked-by: Eric Engestrom <[email protected]> Signed-off-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/intel/compiler/meson.build')
-rw-r--r--src/intel/compiler/meson.build19
1 files changed, 11 insertions, 8 deletions
diff --git a/src/intel/compiler/meson.build b/src/intel/compiler/meson.build
index c54c117223c..19e5926a0d9 100644
--- a/src/intel/compiler/meson.build
+++ b/src/intel/compiler/meson.build
@@ -145,14 +145,17 @@ if with_tests
'fs_saturate_propagation', 'vf_float_conversions',
'vec4_register_coalesce', 'vec4_copy_propagation',
'vec4_cmod_propagation', 'eu_compact', 'eu_validate']
- _exe = executable(
- [t, nir_opcodes_h, ir_expression_operation_h],
- 'test_@[email protected]'.format(t),
- include_directories : [inc_common, inc_intel],
- link_with : [libintel_compiler, libintel_common, libnir, libmesa_util,
- libisl],
- dependencies : [dep_thread, dep_dl, idep_gtest],
+ test(
+ t,
+ executable(
+ [t, nir_opcodes_h, ir_expression_operation_h],
+ 'test_@[email protected]'.format(t),
+ include_directories : [inc_common, inc_intel],
+ link_with : [
+ libintel_compiler, libintel_common, libnir, libmesa_util, libisl,
+ ],
+ dependencies : [dep_thread, dep_dl, idep_gtest],
+ )
)
- test(t, _exe)
endforeach
endif