summaryrefslogtreecommitdiffstats
path: root/src/imgui/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <[email protected]>2019-01-19 20:02:13 +0000
committerLionel Landwerlin <[email protected]>2019-02-21 18:06:05 +0000
commit51047cd2e8a1e834d0345e2eadaeb0da70eb7bfc (patch)
treefb1725b60e680aa6c16c8e520344711c61a8dae6 /src/imgui/meson.build
parentf98fd9d15a9a79ff1b41f1fce27bc285a20aa5bb (diff)
build: move imgui out of src/intel/tools to be reused
Signed-off-by: Lionel Landwerlin <[email protected]> Acked-by: Jason Ekstrand <[email protected]> +1-by: Mike Lothian <[email protected]> +1-by: Tapani Pälli <[email protected]> +1-by: Eric Engestrom <[email protected]> +1-by: Yurii Kolesnykov <[email protected]> +1-by: myfreeweb <[email protected]> +1-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/imgui/meson.build')
-rw-r--r--src/imgui/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/imgui/meson.build b/src/imgui/meson.build
new file mode 100644
index 00000000000..a5c02839be2
--- /dev/null
+++ b/src/imgui/meson.build
@@ -0,0 +1,11 @@
+libimgui_core = static_library(
+ 'intel_imgui_core',
+ files('imgui.cpp', 'imgui_demo.cpp', 'imgui_draw.cpp'),
+ cpp_args : ['-w'],
+ install: false
+)
+
+libimgui_core_dep = declare_dependency(
+ link_with: libimgui_core,
+ include_directories: include_directories('.')
+)