aboutsummaryrefslogtreecommitdiffstats
path: root/src/glx/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2012-05-23 15:23:22 -0700
committerIan Romanick <[email protected]>2012-06-13 11:50:24 -0700
commit2e8c866f104202a1c05a7036b44b0c8c434b9ef3 (patch)
treef162bdfb6159a83d7f8efd0a156901e57aa996bb /src/glx/tests/Makefile.am
parentf68ab0398bde5be6a6d4212bea23c9bbaa75d464 (diff)
glx: Move tests from tests/glx to src/glx/tests
This matches the organization of other unit tests in Mesa. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Brian Paul <[email protected]>
Diffstat (limited to 'src/glx/tests/Makefile.am')
-rw-r--r--src/glx/tests/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/glx/tests/Makefile.am b/src/glx/tests/Makefile.am
new file mode 100644
index 00000000000..e7e2697cb9d
--- /dev/null
+++ b/src/glx/tests/Makefile.am
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = \
+ -I$(top_builddir)/src/gtest/include \
+ -I$(top_builddir)/src/mapi \
+ -I$(top_builddir)/src/glx \
+ -I$(top_builddir)/include \
+ $(X11_CFLAGS)
+
+if HAVE_XCB_GLX_CREATE_CONTEXT
+TESTS = glx_unittest
+check_PROGRAMS = glx_unittest
+
+glx_unittest_SOURCES = \
+ clientinfo_unittest.cpp \
+ create_context_unittest.cpp \
+ fake_glx_screen.cpp
+
+glx_unittest_LDADD = \
+ $(top_builddir)/src/glx/libglx.la \
+ $(top_builddir)/src/gtest/libgtest.la \
+ -lpthread
+
+endif