summaryrefslogtreecommitdiffstats
path: root/src/glx/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2013-02-22 16:45:27 -0800
committerIan Romanick <[email protected]>2013-11-07 18:12:33 -0800
commit8c5330226f391a7a29b6538851090b0ef730a239 (patch)
treed7c876c54d1daf1d1735b8cc02f9848730dc0cdb /src/glx/tests/Makefile.am
parent0cce5538673148ffcd7aa9479f6b88cf9a641352 (diff)
glx/tests: Add unit tests for the DRI2 part of GLX_MESA_query_renderer
After adding $(DEFINES) to AM_CPPFLAGS, the __glXGetCurrentContext wrapper function is no longer needed and causes compile errors. Using the correct defines causes it to be a macro! Signed-off-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/glx/tests/Makefile.am')
-rw-r--r--src/glx/tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/glx/tests/Makefile.am b/src/glx/tests/Makefile.am
index 6995d987d35..4dc358c3261 100644
--- a/src/glx/tests/Makefile.am
+++ b/src/glx/tests/Makefile.am
@@ -6,6 +6,9 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/mesa \
-I$(top_srcdir)/src/glx \
-I$(top_srcdir)/include \
+ -I$(top_srcdir)/include/GL/internal \
+ $(DEFINES) \
+ $(LIBDRM_CFLAGS) \
$(X11_CFLAGS)
TESTS = glx-test
@@ -17,6 +20,7 @@ glx_test_SOURCES = \
enum_sizes.cpp \
fake_glx_screen.cpp \
indirect_api.cpp \
+ query_renderer_implementation_unittest.cpp \
query_renderer_unittest.cpp
glx_test_LDADD = \