summaryrefslogtreecommitdiffstats
path: root/src/glx/tests/Makefile.am
diff options
context:
space:
mode:
authorJohannes Obermayr <[email protected]>2012-12-29 01:52:11 +0100
committerAndreas Boll <[email protected]>2013-01-13 12:38:38 +0100
commitebcabb88cfd19b35cd1b0a327fa055fff0c1b2be (patch)
treef589398bf3122183fa226f9ff54b23d6231761f8 /src/glx/tests/Makefile.am
parent06f3a1f792e5f280c8e83581622b2f4bab811720 (diff)
tests: AM_CPPFLAGS must include $(top_srcdir) instead of $(top_builddir).
Reviewed-by: Andreas Boll <[email protected]>
Diffstat (limited to 'src/glx/tests/Makefile.am')
-rw-r--r--src/glx/tests/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/glx/tests/Makefile.am b/src/glx/tests/Makefile.am
index 83626fd41c6..d940712a6c5 100644
--- a/src/glx/tests/Makefile.am
+++ b/src/glx/tests/Makefile.am
@@ -1,11 +1,11 @@
if HAVE_SHARED_GLAPI
AM_CFLAGS = $(PTHREAD_CFLAGS)
AM_CPPFLAGS = \
- -I$(top_builddir)/src/gtest/include \
- -I$(top_builddir)/src/mapi \
- -I$(top_builddir)/src/mesa \
- -I$(top_builddir)/src/glx \
- -I$(top_builddir)/include \
+ -I$(top_srcdir)/src/gtest/include \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/glx \
+ -I$(top_srcdir)/include \
$(X11_CFLAGS)
TESTS = glx-test
='n128' href='#n128'>128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826 827 828
<?xml version="1.0" encoding="utf-8"?>
<root>
  <!-- 
    Microsoft ResX Schema 
    
    Version 2.0
    
    The primary goals of this format is to allow a simple XML format 
    that is mostly human readable. The generation and parsing of the 
    various data types are done through the TypeConverter classes 
    associated with the data types.
    
    Example:
    
    ... ado.net/XML headers & schema ...
    <resheader name="resmimetype">text/microsoft-resx</resheader>
    <resheader name="version">2.0</resheader>
    <resheader name="reader">System.Resources.ResXResourceReader, System.Windows.Forms, ...</resheader>
    <resheader name="writer">System.Resources.ResXResourceWriter, System.Windows.Forms, ...</resheader>
    <data name="Name1"><value>this is my long string</value><comment>this is a comment</comment></data>
    <data name="Color1" type="System.Drawing.Color, System.Drawing">Blue</data>
    <data name="Bitmap1" mimetype="application/x-microsoft.net.object.binary.base64">
        <value>[base64 mime encoded serialized .NET Framework object]</value>
    </data>
    <data name="Icon1" type="System.Drawing.Icon, System.Drawing" mimetype="application/x-microsoft.net.object.bytearray.base64">
        <value>[base64 mime encoded string representing a byte array form of the .NET Framework object]</value>
        <comment>This is a comment</comment>
    </data>
                
    There are any number of "resheader" rows that contain simple 
    name/value pairs.
    
    Each data row contains a name, and value. The row also contains a 
    type or mimetype. Type corresponds to a .NET class that support 
    text/value conversion through the TypeConverter architecture. 
    Classes that don't support this are serialized and stored with the 
    mimetype set.
    
    The mimetype is used for serialized objects, and tells the 
    ResXResourceReader how to depersist the object. This is currently not 
    extensible. For a given mimetype the value must be set accordingly:
    
    Note - application/x-microsoft.net.object.binary.base64 is the format 
    that the ResXResourceWriter will generate, however the reader can 
    read any of the formats listed below.
    
    mimetype: application/x-microsoft.net.object.binary.base64
    value   : The object must be serialized with 
            : System.Runtime.Serialization.Formatters.Binary.BinaryFormatter
            : and then encoded with base64 encoding.
    
    mimetype: application/x-microsoft.net.object.soap.base64
    value   : The object must be serialized with 
            : System.Runtime.Serialization.Formatters.Soap.SoapFormatter
            : and then encoded with base64 encoding.

    mimetype: application/x-microsoft.net.object.bytearray.base64
    value   : The object must be serialized into a byte array 
            : using a System.ComponentModel.TypeConverter
            : and then encoded with base64 encoding.
    -->
  <xsd:schema id="root" xmlns="" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
    <xsd:import namespace="http://www.w3.org/XML/1998/namespace" />
    <xsd:element name="root" msdata:IsDataSet="true">
      <xsd:complexType>
        <xsd:choice maxOccurs="unbounded">
          <xsd:element name="metadata">
            <xsd:complexType>
              <xsd:sequence>
                <xsd:element name="value" type="xsd:string" minOccurs="0" />
              </xsd:sequence>
              <xsd:attribute name="name" use="required" type="xsd:string" />
              <xsd:attribute name="type" type="xsd:string" />
              <xsd:attribute name="mimetype" type="xsd:string" />
              <xsd:attribute ref="xml:space" />
            </xsd:complexType>
          </xsd:element>
          <xsd:element name="assembly">
            <xsd:complexType>
              <xsd:attribute name="alias" type="xsd:string" />
              <xsd:attribute name="name" type="xsd:string" />
            </xsd:complexType>
          </xsd:element>
          <xsd:element name="data">
            <xsd:complexType>
              <xsd:sequence>
                <xsd:element name="value" type="xsd:string" minOccurs="0" msdata:Ordinal="1" />
                <xsd:element name="comment" type="xsd:string" minOccurs="0" msdata:Ordinal="2" />
              </xsd:sequence>
              <xsd:attribute name="name" type="xsd:string" use="required" msdata:Ordinal="1" />
              <xsd:attribute name="type" type="xsd:string" msdata:Ordinal="3" />
              <xsd:attribute name="mimetype" type="xsd:string" msdata:Ordinal="4" />
              <xsd:attribute ref="xml:space" />
            </xsd:complexType>
          </xsd:element>
          <xsd:element name="resheader">
            <xsd:complexType>
              <xsd:sequence>
                <xsd:element name="value" type="xsd:string" minOccurs="0" msdata:Ordinal="1" />
              </xsd:sequence>
              <xsd:attribute name="name" type="xsd:string" use="required" />
            </xsd:complexType>
          </xsd:element>
        </xsd:choice>
      </xsd:complexType>
    </xsd:element>
  </xsd:schema>
  <resheader name="resmimetype">
    <value>text/microsoft-resx</value>
  </resheader>
  <resheader name="version">
    <value>2.0</value>
  </resheader>
  <resheader name="reader">
    <value>System.Resources.ResXResourceReader, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</value>
  </resheader>
  <resheader name="writer">
    <value>System.Resources.ResXResourceWriter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</value>
  </resheader>
  <data name="Advanced_AdaptiveBFramesToolTip" xml:space="preserve">
    <value>x264 has a variety of algorithms to decide when to use B-frames and how many to use.

Fast mode takes roughly the same amount of time no matter how many B-frames you specify.  However, while fast, its decisions are often suboptimal.

Optimal mode gets slower as the maximum number of B-Frames increases, but makes much more accurate decisions, especially when used with B-pyramid.</value>
  </data>
  <data name="Advanced_AdaptiveDirectModeToolTip" xml:space="preserve">
    <value>H.264 allows for two different prediction modes, spatial and temporal, in B-frames.

Spatial, the default, is almost always better, but temporal is sometimes useful too.

x264 can, at the cost of a small amount of speed (and accordingly for a small compression gain), adaptively select which is better for each particular frame.</value>
  </data>
  <data name="Advanced_AdaptiveQuantizationStrengthToolTip" xml:space="preserve">
    <value>Adaptive quantization controls how the encoder distributes bits across the frame.
Higher values take more bits away from edges and complex areas to improve areas with finer detail.</value>
  </data>
  <data name="Advanced_AnalysisToolTip" xml:space="preserve">
    <value>Mode decision picks from a variety of options to make its decision: this option chooses what options those are.  
Fewer partitions to check means faster encoding, at the cost of worse decisions, since the best option might have been one that was turned off.</value>
  </data>
  <data name="Advanced_BFramesToolTip" xml:space="preserve">
    <value>Sane values are ~2-5.  
This specifies the maximum number of sequential B-frames that the encoder can use. 
 Large numbers generally won't help significantly unless Adaptive B-frames is set to Optimal.  
Cel-animated source material and B-pyramid also significantly increase the usefulness of larger values. 
Baseline profile, as required for iPods and similar devices, requires B-frames to be set to 0 (off).</value>
  </data>
  <data name="Advanced_CabacToolTip" xml:space="preserve">
    <value>After the encoder has done its work, it has a bunch of data that needs to be compressed losslessly, similar to ZIP or RAR. H.264 provides two options for this: CAVLC and CABAC.  CABAC decodes a lot slower but compresses significantly better (10-30%), especially at lower bitrates. If you're looking to minimize CPU requirements for video playback, disable this option. Baseline profile, as required for iPods and similar devices, requires CABAC to be disabled.</value>
  </data>
  <data name="Advanced_DeblockingToolTip" xml:space="preserve">
    <value>H.264 has a built-in deblocking filter that smooths out blocking artifacts after decoding each frame.  This not only improves visual quality, but also helps compression significantly. 
The deblocking filter takes a lot of CPU power, so if you're looking to minimize CPU requirements for video playback, disable it.

The deblocking filter has two adjustable parameters, "strength" and "threshold". 
The former controls how strong (or weak) the deblocker is, while the latter controls how many (or few)  edges it applies to. 
Lower values mean less deblocking, higher values mean more deblocking. The default is 0 (normal strength) for both parameters.</value>
  </data>
  <data name="Advanced_EightByEightDctToolTip" xml:space="preserve">
    <value>The 8x8 transform is the single most useful feature of x264 in terms of compression-per-speed.  
It improves compression by at least 5% at a very small speed cost and may provide an unusually high visual quality benefit compared to its compression gain.  
However, it requires High Profile, which many devices may not support.</value>
  </data>
  <data name="Advanced_MotionEstimationMethodToolTip" xml:space="preserve">
    <value>Controls the motion estimation method. Motion estimation is how the encoder estimates how each block of pixels in a frame has moved.  
A better motion search method improves compression at the cost of speed.

Diamond: performs an extremely fast and simple search using a diamond pattern.

Hexagon: performs a somewhat more effective but slightly slower search using a hexagon pattern.

Uneven Multi-Hex: performs a very wide search using a variety of patterns, more accurately capturing complex motion.

Exhaustive: performs a "dumb" search of every pixel in a wide area.  Significantly slower for only a small compression gain.

Transformed Exhaustive: Like exhaustive, but makes even more accurate decisions. Accordingly, somewhat slower, also for only a small improvement.</value>
  </data>
  <data name="Advanced_MotionEstimationRangeToolTip" xml:space="preserve">
    <value>This is the distance x264 searches from its best guess at the motion of a block in order to try to find its actual motion.  

The default is fine for most content, but extremely high motion video, especially at HD resolutions, may benefit from higher ranges, albeit at a high speed cost.</value>
  </data>
  <data name="Advanced_NoDctDecimateToolTip" xml:space="preserve">
    <value>x264 normally zeroes out nearly-empty data blocks to save bits to be better used for some other purpose in the video.  
However, this can sometimes have slight negative effects on retention of subtle grain and dither.  
Don't touch this unless you're having banding issues or other such cases where you are having trouble keeping fine noise.</value>
  </data>
  <data name="Advanced_PsychovisualRateDistortionToolTip" xml:space="preserve">
    <value>Psychovisual Rate Distortion means x264 tries to retain detail, for better quality to the human eye, 
as opposed to trying to maximize quality the way a computer understands it, through signal-to-noise ratios that have trouble telling apart fine detail and noise.</value>
  </data>
  <data name="Advanced_PsychovisualTrellisToolTip" xml:space="preserve">
    <value>Psychovisual Trellis tries to retain more sharpness and detail, but can cause artifacting.
It is considered experimental, which is why it's off by default. Good values are 0.1 to 0.2.</value>
  </data>
  <data name="Advanced_PyramidalBFramesToolTip" xml:space="preserve">
    <value>B-pyramid improves compression by creating a pyramidal structure (hence the name) of B-frames, allowing B-frames to 
reference each other to improve compression.  

Requires Max B-frames greater than 1; optimal adaptive B-frames is strongly recommended for full compression benefit.</value>
  </data>
  <data name="Advanced_ReferenceFramesToolTip" xml:space="preserve">
    <value>Sane values are ~1-6.

The more you add, the better the compression, but the slower the encode.

Cel animation tends to benefit from more reference frames a lot more than film content.

Note that many hardware devices have limitations on the number of supported reference frames, so if you're encoding for a handheld or standalone player, don't touch this unless you're absolutely sure you know what you're doing!</value>
  </data>
  <data name="Advanced_SubpixelMotionEstimationToolTip" xml:space="preserve">
    <value>This setting controls both subpixel-precision motion estimation and mode decision methods.

Subpixel motion estimation is used for refining motion estimates beyond mere pixel accuracy, improving compression.

Mode decision is the method used to choose how to encode each block of the frame: a very important decision.

SAD is the fastest method, followed by SATD, RD, RD refinement, and the slowest, QPRD.
6 or higher is strongly recommended: Psy-RD, a very powerful psy optimization that helps retain detail, requires RD.
10, the most powerful and slowest option, requires trellis=2.</value>
  </data>
  <data name="Advanced_TrellisToolTip" xml:space="preserve">
    <value>Trellis fine-tunes the rounding of transform coefficients to squeeze out 3-5% more compression at the cost of some speed. 
"Always" uses trellis not only during the main encoding process, but also during analysis, which improves compression even more, albeit at great speed cost. 

Trellis costs more speed at higher bitrates.</value>
  </data>
  <data name="Advanced_WeightPToolTip" xml:space="preserve">
    <value>Performs extra analysis to decide upon weighting parameters for each frame.  
This improves overall compression slightly and improves the quality of fades greatly. 
Baseline profile, as required for iPods and similar devices, requires weighted P-frame prediction to be disabled.  
Note that some devices and players, even those that support Main Profile, 
may have problems with Weighted P-frame prediction: the Apple TV is completely incompatible with it, for example.</value>
  </data>
  <data name="Video_EncoderExtraArgs" xml:space="preserve">
    <value>The full list of encoder parameters: 
{0}</value>
  </data>
  <data name="Video_x264FastDecode" xml:space="preserve">
    <value>Reduce decoder CPU usage.

Set this if your device is struggling to play the output. (i.e. dropped frames)</value>
  </data>
  <data name="Video_LosslessWarning" xml:space="preserve">
    <value>Warning: RF 0 is Lossless!</value>
  </data>
  <data name="Video_LosslessWarningTooltip" xml:space="preserve">
    <value>A value of 0 means lossless and will result in a file size that is larger than the original source, 
unless the source was also lossless. 

x264 and x265's scale is logarithmic and lower values correspond to higher quality. 

So small increases in value will result in progressively larger increases in the resulting file size.</value>
  </data>
  <data name="AddPreset_PictureSizeMode" xml:space="preserve">
    <value>You can optionally store a picture settings with this preset. There are 3 modes:

None:  Picture settings are not stored in the preset. When loading a source, they will remain as-is within the bounds of the source resolution. This also affects Anamorphic, modulus, cropping etc.

Custom: You can optionally set a Maximum width and Height. When doing this an encode will be less than or equal to these values. Keep Aspect Ratio will be automatically turned on.

Source Maximum:  Always encode at the sources resolution where possible.</value>
  </data>
  <data name="Advanced_EncoderOptions" xml:space="preserve">
    <value>The options passed to the x264 encoder. 
The above controls are only a subset of useful x264 parameters. 
This box allows you to add or modify additional or current parameters as desired. </value>
  </data>
  <data name="About_GPL" xml:space="preserve">
    <value>Copyright (C) 2003-2016 The HandBrake Team

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.</value>
  </data>
  <data name="Advanced_NotInUse" xml:space="preserve">
    <value>The x264 Preset / Tune / Profile and Level options are currently in use on the Video Tab. 

To enable this tab, check the "Use Advanced Tab instead" option on the Video Tab.

If you do not use this tab, it can be hidden from: Tools Menu &gt; Options &gt; Advanced.</value>
  </data>
  <data name="QueueSelection_AutoNameWarning" xml:space="preserve">
    <value>WARNING: You do not have automatic file naming turned on. Please enable this in options.</value>
  </data>
  <data name="QueueSelection_AutoTrackSelectionWarning" xml:space="preserve">
    <value>WARNING: You do not currently have automatic audio and subtitle track selection setup. You can setup the default track selection behaviour in options.</value>
  </data>
  <data name="Presets_ResetComplete" xml:space="preserve">
    <value>The Built-in presets have been reset.</value>
  </data>
  <data name="Presets_ResetHeader" xml:space="preserve">
    <value>Reset Complete</value>
  </data>
  <data name="Video_HigherQuality" xml:space="preserve">
    <value>Higher Quality |</value>
  </data>
  <data name="Video_LowQuality" xml:space="preserve">
    <value>| Lower Quality</value>
  </data>
  <data name="Video_PlaceboQuality" xml:space="preserve">
    <value>Placebo Quality |</value>
  </data>
  <data name="Video_QuickSyncNotAvailable" xml:space="preserve">
    <value>QuickSync hardware not detected or enabled! 

In order to use the QuickSync encoder, you must:

- Have a Intel CPU with HD Graphics and QuickSync support. 4th Generation Haswell or newer parts are recommended for best quality.
- Have the HD Graphics enabled.
- On older versions of windows before 8, a monitor connected to the HD Graphics or GPU Virtualisation software installed is also required.</value>
  </data>
  <data name="Video_ScalingModes" xml:space="preserve">
    <value>Requires a graphics card that supports OpenCL 1.1 or later. It will fallback to Lanczos software scaling when it is not available for use. Performance gain up to 5%. Minor decrease in quality in some cases.</value>
  </data>
  <data name="Error" xml:space="preserve">
    <value>Error</value>
  </data>
  <data name="Main_AutoAdd_AudioAndSubWarning" xml:space="preserve">
    <value>Warning: It is not currently possible to use this feature if you require specific subtitle or audio tracks that the automatic selection feature (see options) doesn't support! Tracks are reset with every new source / title selected.</value>
  </data>
  <data name="Main_TurnOnAutoFileNaming" xml:space="preserve">
    <value>You must turn on automatic file naming AND set a default path in preferences before you can add to the queue.</value>
  </data>
  <data name="Warning" xml:space="preserve">
    <value>Warning</value>
  </data>
  <data name="AreYouSure" xml:space="preserve">
    <value>Are you sure?</value>
  </data>
  <data name="HandBrake_Title" xml:space="preserve">
    <value>HandBrake</value>
  </data>
  <data name="Main_AlreadyEncoding" xml:space="preserve">
    <value>HandBrake is already encoding.</value>
  </data>
  <data name="Main_ChooseDestination" xml:space="preserve">
    <value>Please choose a destination for where you would like the encoded file to be saved.</value>
  </data>
  <data name="Main_DestinationOverwrite" xml:space="preserve">
    <value>The current file already exists, do you wish to overwrite it?</value>
  </data>
  <data name="Main_DuplicateDestinationOnQueue" xml:space="preserve">
    <value>There are jobs on the queue with the same destination path. Please choose a different path for this job.</value>
  </data>
  <data name="Main_JobsPending_addon" xml:space="preserve">
    <value>   Pending Jobs {7}</value>
  </data>
  <data name="Main_NewDefaultPreset" xml:space="preserve">
    <value>New Default Preset Set: {0}</value>
  </data>
  <data name="Main_NewUpdate" xml:space="preserve">
    <value>A New Update is Available. Goto Tools Menu &gt; Options to Install</value>
  </data>
  <data name="Main_NoPresetSelected" xml:space="preserve">
    <value>No Preset selected.</value>
  </data>
  <data name="Main_NoUpdateOfBuiltInPresets" xml:space="preserve">
    <value>You can not modify built in presets. Please select one of your own presets.</value>
  </data>
  <data name="Main_PleaseSelectFolder" xml:space="preserve">
    <value>Please select a folder.</value>
  </data>
  <data name="Main_PreparingToEncode" xml:space="preserve">
    <value>Preparing to encode ...</value>
  </data>
  <data name="Main_PresetErrorBuiltInName" xml:space="preserve">
    <value>You can not import a preset with the same name as a built-in preset.</value>
  </data>
  <data name="Main_PresetOverwriteWarning" xml:space="preserve">
    <value>This preset appears to already exist. Would you like to overwrite it?</value>
  </data>
  <data name="Main_Presets" xml:space="preserve">
    <value>Presets</value>
  </data>
  <data name="Main_PresetUpdateConfrimation" xml:space="preserve">
    <value>Are you sure you wish to update the selected preset?</value>
  </data>
  <data name="Main_PresetUpdated" xml:space="preserve">
    <value>The Preset has now been updated with your current settings.</value>
  </data>
  <data name="Main_PresetUpdateNotification" xml:space="preserve">
    <value>HandBrake has determined your built-in presets are out of date... These presets will now be updated.
Your custom presets have not been updated so you may have to re-create these by deleting and re-adding them. 
The previous user_presets.xml file was backed up.</value>
  </data>
  <data name="Main_QueueFinished" xml:space="preserve">
    <value>Queue Finished</value>
  </data>
  <data name="Main_ScanCancelled" xml:space="preserve">
    <value>Scan Cancelled.</value>
  </data>
  <data name="Main_ScanCompleted" xml:space="preserve">
    <value>Scan Completed</value>
  </data>
  <data name="Main_ScanFailed_NoReason" xml:space="preserve">
    <value>Scan failed: </value>
  </data>
  <data name="Main_ScanFailled_CheckLog" xml:space="preserve">
    <value>Scan Failed... Please See Activity Log for details.</value>
  </data>
  <data name="Main_ScanningPleaseWait" xml:space="preserve">
    <value>Scanning source, please wait...</value>
  </data>
  <data name="Main_ScanningTitleXOfY" xml:space="preserve">
    <value>Scanning Title {0} of {1} ({2}%)</value>
  </data>
  <data name="Main_ScanSource" xml:space="preserve">
    <value>You must first scan a source and setup your job before starting an encode. Click the 'Source' button on the toolbar to continue.</value>
  </data>
  <data name="Main_SelectPreset" xml:space="preserve">
    <value>Please select a preset.</value>
  </data>
  <data name="Main_SelectPresetForUpdate" xml:space="preserve">
    <value>Please select a preset to update.</value>
  </data>
  <data name="Main_SelectSource" xml:space="preserve">
    <value>Select 'Source' to continue</value>
  </data>
  <data name="Main_XEncodesPending" xml:space="preserve">
    <value>{0} Encodes Pending</value>
  </data>
  <data name="Notice" xml:space="preserve">
    <value>Notice</value>
  </data>
  <data name="Overwrite" xml:space="preserve">
    <value>Overwrite?</value>
  </data>
  <data name="Question" xml:space="preserve">
    <value>Question</value>
  </data>
  <data name="State_Ready" xml:space="preserve">
    <value>Ready</value>
  </data>
  <data name="Updated" xml:space="preserve">
    <value>Updated</value>
  </data>
  <data name="Preset_OldVersion_Header" xml:space="preserve">
    <value>Preset Version</value>
  </data>
  <data name="Preset_OldVersion_Message" xml:space="preserve">
    <value>The preset you are trying to import is from a different version of HandBrake. 
 It may not be possible to import all the values from this preset. 

Do you wish to proceed?</value>
  </data>
  <data name="Preset_UnableToImport_Header" xml:space="preserve">
    <value>Unable to import preset!</value>
  </data>
  <data name="Preset_UnableToImport_Message" xml:space="preserve">
    <value>Unable to import the preset as it appears to be corrupted or from an older version of HandBrake.</value>
  </data>
  <data name="Main_SetDestination" xml:space="preserve">
    <value>You must first set the destination path for the output file before adding to the queue.</value>
  </data>
  <data name="Main_InvalidDestination" xml:space="preserve">
    <value>The entered destination path contained illegal characters and will not be updated.</value>
  </data>
  <data name="Preview" xml:space="preserve">
    <value>Preview</value>
  </data>
  <data name="Preview_Scaled" xml:space="preserve">
    <value>Preview (Scaled)</value>
  </data>
  <data name="PictureSettings_OutputResolution" xml:space="preserve">
    <value>Output: {0}</value>
  </data>
  <data name="Options_AdditionalFormatOptions" xml:space="preserve">
    <value>The format of the output file. In addition to any supported file system character, you can use the following placeholders that will be replaced when you change title or scan a source.

Live Update Options: {source} {title} {chapters} 
Non-Live Options: {date} {time} {quality} {bitrate} {preset} (These only change if you scan a new source, change title or chapters)</value>
  </data>
  <data name="Options_DefaultPathAdditionalParams" xml:space="preserve">
    <value>Available additional Options: {source_path} or {source_folder_name} 

Not both at the same time!</value>
  </data>
  <data name="Main_MatchingFileOverwriteWarning" xml:space="preserve">
    <value>You cannot encode to a file with the same path and filename as the source file. Please update the destination filename so that it does not match the source file.</value>
  </data>
  <data name="Main_UnableToLoadHelpMessage" xml:space="preserve">
    <value>Your system prevented HandBrake from launching a web browser.</value>
  </data>
  <data name="Main_UnableToLoadHelpSolution" xml:space="preserve">
    <value>You can still access the help pages by visiting the website directly at: https://handbrake.fr</value>
  </data>
  <data name="Main_PresetImportFailed" xml:space="preserve">
    <value>Unable to import the selected preset.</value>
  </data>
  <data name="Main_PresetImportFailedSolution" xml:space="preserve">
    <value>The preset may be corrupted or from an older version of HandBrake which is not supported. 
Presets from older versions must be re-created in the current version.</value>
  </data>
  <data name="Advanced_NoOptionsPaneAvailable" xml:space="preserve">
    <value>There is no options pane available for this encoder.

Please use the 'Extra Options' box on the 'Video' tab to input any additional encoder parameters you may need.</value>
  </data>
  <data name="Video_EncoderExtraArgsTooltip" xml:space="preserve">
    <value>Additional advanced arguments that can be passed to the video encoder.</value>
  </data>
  <data name="Main_SourceDestinationMatchError" xml:space="preserve">
    <value>You cannot overwrite the source file you want to convert.
Please choose a different filename.</value>
  </data>
  <data name="Subtitles_BurnInBehaviourModes" xml:space="preserve">
    <value>None - Only tracks where the container does not support the format will be burned in.
Foreign Audio Track - The Foreign Audio track will be burned in if available. 
First Track - The first track will be burned in.
Foreign Audio Preferred, else First - If the foreign audio track exists, it will be burned in, otherwise the first track will be chosen.</value>
  </data>
  <data name="Main_ScanNoTitlesFound" xml:space="preserve">
    <value>No valid source or titles found.</value>
  </data>
  <data name="Main_ScanNoTitlesFoundMessage" xml:space="preserve">
    <value>HandBrake will not be able to encode the seleteced source as it did not find a valid source with titles to encode. 
This could be due to one of the following reasons:
- The source file is not a valid video file or is in a format that HandBrake does not support.
- The source may be copy protected or include DRM. Please note that HandBrake does not support the removal of copy protections.

The Activity log may have further information.</value>
  </data>
  <data name="Main_QueueLabel" xml:space="preserve">
    <value>Show Queue{0}</value>
  </data>
  <data name="Main_Start" xml:space="preserve">
    <value>Start Encode</value>
  </data>
  <data name="Main_StartQueue" xml:space="preserve">
    <value>Start Queue</value>
  </data>
  <data name="MainViewModel_CanNotDeleteDefaultPreset" xml:space="preserve">
    <value>You can not delete the default preset. Please set another preset as default first.</value>
  </data>
  <data name="MainViewModel_PresetRemove_AreYouSure" xml:space="preserve">
    <value>Are you sure you want to delete the preset: </value>
  </data>
  <data name="MainViewModel_EncodeStatusChanged_StatusLabel" xml:space="preserve">
    <value>Encoding: Pass {0} of {1},  {2:00.00}%, FPS: {3:000.0},  Avg FPS: {4:000.0},  Time Remaining: {5},  Elapsed: {6:d\:hh\:mm\:ss}</value>
  </data>
  <data name="AddPresetViewModel_PresetMustProvideName" xml:space="preserve">
    <value>A Preset must have a Name. Please fill out the Preset Name field.</value>
  </data>
  <data name="AddPresetViewModel_PresetWithSameNameOverwriteWarning" xml:space="preserve">
    <value>A Preset with this name already exists. Would you like to overwrite it?</value>
  </data>
  <data name="AddPresetViewModel_YouMustFirstScanSource" xml:space="preserve">
    <value>You must first scan a source to use the 'Source Maximum' Option.</value>
  </data>
  <data name="AddPresetViewModel_CustomWidthHeightFieldsRequired" xml:space="preserve">
    <value>The Custom Width or Height fields must be filled in for the 'Custom' option.</value>
  </data>
  <data name="AddPresetViewModel_UnableToAddPreset" xml:space="preserve">
    <value>Unable to add preset</value>
  </data>
  <data name="UnknownError" xml:space="preserve">
    <value>Unknown Error</value>
  </data>
  <data name="AudioViewModel_AudioDefaults" xml:space="preserve">
    <value>Audio Defaults</value>
  </data>
  <data name="AudioViewModel_AudioTracks" xml:space="preserve">
    <value>Audio Tracks</value>
  </data>
  <data name="AudioViewModel_ConfigureDefaults" xml:space="preserve">
    <value>Configure Defaults</value>
  </data>
  <data name="AudioViewModel_SwitchBackToTracks" xml:space="preserve">
    <value>Switch Back To Tracks</value>
  </data>
  <data name="ChaptersViewModel_UnableToExportChaptersWarning" xml:space="preserve">
    <value>Unable to save Chapter Markers file! </value>
  </data>
  <data name="ChaptersViewModel_UnableToExportChaptersMsg" xml:space="preserve">
    <value>Chapter marker names will NOT be saved in your encode.</value>
  </data>
  <data name="CountdownAlertViewModel_NoticeMessage" xml:space="preserve">
    <value>The following action '{0}' will occur in {1} seconds.</value>
  </data>
  <data name="ErrorViewModel_IfTheProblemPersists" xml:space="preserve">
    <value>If the problem presists, please try restarting HandBrake.</value>
  </data>
  <data name="ErrorViewModel_NoFurtherInformation" xml:space="preserve">
    <value>There is no further information available about this error.</value>
  </data>
  <data name="ErrorViewModel_UnknownError" xml:space="preserve">
    <value>An Unknown Error has occured.</value>
  </data>
  <data name="OptionsViewModel_NewUpdate" xml:space="preserve">
    <value>A New Update is Available! Please check the website for release notes.</value>
  </data>
  <data name="OptionsViewModel_64bitAvailable" xml:space="preserve">
    <value>Your system supports the 64bit version of HandBrake! This offers performance and stability improvements over this 32bit version.
    Please check the website for release notes.</value>
  </data>
  <data name="OptionsViewModel_NoNewUpdates" xml:space="preserve">
    <value>There are no new updates at this time.</value>
  </data>
  <data name="OptionsViewModel_UpdateDownloaded" xml:space="preserve">
    <value>Update Downloaded</value>
  </data>
  <data name="OptionsViewModel_UpdateServiceUnavailable" xml:space="preserve">
    <value>Update Service Unavailable. You can try downloading the update from https://handbrake.fr</value>
  </data>
  <data name="OptionsViewModel_UpdateFailed" xml:space="preserve">
    <value>Update Failed. You can try downloading the update from https://handbrake.fr</value>
  </data>
  <data name="PictureSettingsViewModel_StorageDisplayLabel" xml:space="preserve">
    <value>Storage: {0}x{1}, Display: {2}x{3}</value>
  </data>
  <data name="QueueSelectionViewModel_AddToQueue" xml:space="preserve">
    <value>Add to Queue</value>
  </data>
  <data name="QueueViewModel_NoEncodesPending" xml:space="preserve">
    <value>No encodes pending</value>
  </data>
  <data name="QueueViewModel_NoJobsPending" xml:space="preserve">
    <value>There are no jobs currently encoding</value>
  </data>
  <data name="QueueViewModel_Queue" xml:space="preserve">
    <value>Queue</value>
  </data>
  <data name="QueueViewModel_ClearQueueConfrimation" xml:space="preserve">
    <value>Are you sure you wish to clear the queue?</value>
  </data>
  <data name="Confirm" xml:space="preserve">
    <value>Confirm</value>
  </data>
  <data name="QueueViewModel_JobsPending" xml:space="preserve">
    <value>{0} jobs pending</value>
  </data>
  <data name="QueueViewModel_QueuePending" xml:space="preserve">
    <value>Queue Paused</value>
  </data>
  <data name="QueueViewModel_QueuePauseNotice" xml:space="preserve">
    <value>The Queue has been paused. The currently running job will run to completion and no further jobs will start.</value>
  </data>
  <data name="QueueViewModel_DelSelectedJobConfirmation" xml:space="preserve">
    <value>Are you sure you want to delete the selected jobs?</value>
  </data>
  <data name="QueueViewModel_JobCurrentlyRunningWarning" xml:space="preserve">
    <value>This encode is currently in progress. If you delete it, the encode will be stopped. Are you sure you wish to proceed?</value>
  </data>
  <data name="QueueViewModel_NoPendingJobs" xml:space="preserve">
    <value>There are no pending jobs.</value>
  </data>
  <data name="QueueViewModel_EditConfrimation" xml:space="preserve">
    <value>Are you sure you wish to edit this job? It will be removed from the queue and sent to the main window.</value>
  </data>
  <data name="QueueViewModel_QueueReady" xml:space="preserve">
    <value>Queue Ready</value>
  </data>
  <data name="QueueViewModel_QueueNotRunning" xml:space="preserve">
    <value>Queue Not Running</value>
  </data>
  <data name="QueueViewModel_QueueCompleted" xml:space="preserve">
    <value>Queue Completed</value>
  </data>
  <data name="QueueViewModel_LastJobFinished" xml:space="preserve">
    <value>Last Queued Job Finished</value>
  </data>
  <data name="QueueViewModel_QueueStarted" xml:space="preserve">
    <value>Queue Started</value>
  </data>
  <data name="QueueViewModel_QueueStatusDisplay" xml:space="preserve">
    <value>Encoding: Pass {0} of {1},  {2:00.00}%, FPS: {3:000.0},  Avg FPS: {4:000.0},  Time Remaining: {5},  Elapsed: {6:d\:hh\:mm\:ss}</value>
  </data>
  <data name="ShellViewModel_CanClose" xml:space="preserve">
    <value>An Encode is currently running. Exiting HandBrake will stop this encode.
Are you sure you wish to exit HandBrake?</value>
  </data>
  <data name="StaticPreviewViewModel_Title" xml:space="preserve">
    <value>Picture Preview</value>
  </data>
  <data name="StaticPreview_UnableToDeletePreview" xml:space="preserve">
    <value>Unable to delete previous preview file. You may need to restart the application.</value>
  </data>
  <data name="StaticPreviewViewModel_ScanFirst" xml:space="preserve">
    <value>You must first scan a source and setup your encode before creating a preview.</value>
  </data>
  <data name="StaticPreviewViewModel_UnableToFindVLC" xml:space="preserve">
    <value>Unable to detect VLC Player. 
Please make sure VLC is installed and the directory specified in HandBrake's options is correct. (See: "Tools Menu &gt; Options &gt; Picture Tab")</value>
  </data>
  <data name="StaticPreviewViewModel_UnableToPlayFile" xml:space="preserve">
    <value>Unable to find the preview file. Either the file was deleted or the encode failed. Check the activity log for details.</value>
  </data>
  <data name="StaticPreviewViewModel_AlreadyEncoding" xml:space="preserve">
    <value>Handbrake is already encoding a video! Only one file can be encoded at any one time.</value>
  </data>
  <data name="SubtitlesViewModel_SubDefaults" xml:space="preserve">
    <value>Subtitle Defaults</value>
  </data>
  <data name="SubtitlesViewModel_SubTracks" xml:space="preserve">
    <value>Subtitle Tracks</value>
  </data>
  <data name="SubtitlesViewModel_SwitchToTracks" xml:space="preserve">
    <value>Switch Back To Tracks</value>
  </data>
  <data name="SubtitlesViewModel_ConfigureDefaults" xml:space="preserve">
    <value>Configure Defaults</value>
  </data>
  <data name="PresetService_ArchiveFile" xml:space="preserve">
    <value>Archived File:</value>
  </data>
  <data name="PresetService_PresetsOutOfDate" xml:space="preserve">
    <value>HandBrake has detected your presets file is from an older version.
It will try and load the file anyway.
If it fails, it will archive off the old file and create a new one.</value>
  </data>
  <data name="PresetService_UnableToLoad" xml:space="preserve">
    <value>Unable to load presets.</value>
  </data>
  <data name="PresetService_UnableToLoadPresets" xml:space="preserve">
    <value>HandBrake was unable to load your presets file. It may have been from an older unsupported version of HandBrake or corrupted. 

Your old presets file was archived to:</value>
  </data>
  <data name="Main_QueueFinishedErrors" xml:space="preserve">
    <value> with {0} errors or cancellations detected.</value>
  </data>
  <data name="MainViewModel_LowDiskSpace" xml:space="preserve">
    <value>Low Disk Space</value>
  </data>
  <data name="MainViewModel_LowDiskSpaceWarning" xml:space="preserve">
    <value>Warning, you are running low on disk space. HandBrake will not be able to complete this encode if you run out of space. </value>
  </data>
  <data name="ChaptersViewModel_UnableToImportChaptersMalformedLineMsg" xml:space="preserve">
    <value>Line {0} is invalid. Nothing will be imported.</value>
  </data>
  <data name="ChaptersViewModel_UnableToImportChaptersWarning" xml:space="preserve">
    <value>Unable to import chapter file</value>
  </data>
  <data name="ChaptersViewModel_UnableToImportChaptersLineDoesNotHaveAtLeastTwoColumns" xml:space="preserve">
    <value>All lines in chapters file must have at least 2 columns of data</value>
  </data>
  <data name="ChaptersViewModel_UnableToImportChaptersFirstColumnMustContainOnlyIntegerNumber" xml:space="preserve">
    <value>First column in chapters file must only contain a integer number value higher than zero (0)</value>
  </data>
  <data name="ChaptersViewModel_UnsupportedFileFormatMsg" xml:space="preserve">
    <value>Chapter files of type '{0}' are not currently supported.</value>
  </data>
  <data name="ChaptersViewModel_UnsupportedFileFormatWarning" xml:space="preserve">
    <value>Unsupported chapter file type</value>
  </data>
  <data name="ChaptersViewModel_ValidationFailedWarning" xml:space="preserve">
    <value>Invalid chapter information for source media</value>
  </data>
  <data name="ChaptersViewModel_ValidateImportedChapters_ChapterCountMismatch" xml:space="preserve">
    <value>The number of chapters on the source media 
and the number of chapters in the input file do not match ({0} vs {1}).

Do you still want to import the chapter names?</value>
  </data>
  <data name="ChaptersViewModel_ValidateImportedChapters_ChapterCountMismatchMsg" xml:space="preserve">
    <value>The number of chapters on the source media 
and the number of chapters in the input file do not match ({0} vs {1}).

Do you still want to import the chapter names?</value>
  </data>
  <data name="ChaptersViewModel_ValidateImportedChapters_ChapterCountMismatchWarning" xml:space="preserve">
    <value>Chapter count doesn't match between source and input file</value>
  </data>
  <data name="ChaptersViewModel_ValidateImportedChapters_ChapterDurationMismatchMsg" xml:space="preserve">
    <value>The reported duration of the chapters on the source media 
and the duration of chapters in the input file differ greatly.

It is very likely that this chapter file was produced from a different source media.

Are you sure you want to import the chapter names?</value>
  </data>
  <data name="ChaptersViewModel_ValidateImportedChapters_ChapterDurationMismatchWarning" xml:space="preserve">
    <value>Chapter duration doesn't match between source and input file</value>
  </data>
  <data name="ScanService_ScanStopFailed" xml:space="preserve">
    <value>An error occured when trying to stop the scan. Please restart HandBrake.</value>
  </data>
  <data name="Presets_PresetForceReset" xml:space="preserve">
    <value>HandBrake is unable to upgrade your presets file to a new version format.
Your preset file will be archived and new one created. You will need to re-create your own presets.</value>
  </data>
  <data name="SettingService_SaveErrorReset" xml:space="preserve">
    <value>Any settings you changed may need to be reset the next time HandBrake launches.</value>
  </data>
  <data name="UserSettings_AnErrorOccured" xml:space="preserve">
    <value>A problem occured when trying to save your preferences.</value>
  </data>
  <data name="UserSettings_YourSettingsHaveBeenReset" xml:space="preserve">
    <value>Warning, your settings have been reset!</value>
  </data>
  <data name="UserSettings_YourSettingsAreCorrupt" xml:space="preserve">
    <value>Your user settings file was corrupted or inaccessible. Settings have been reset to defaults.</value>
  </data>
  <data name="UserSettings_UnableToLoad" xml:space="preserve">
    <value>Unable to load user settings file: {0}</value>
  </data>
  <data name="UserSettings_UnableToLoadSolution" xml:space="preserve">
    <value>Your user settings file appears to be inaccessible or corrupted. You may have to delete the file and let HandBrake generate a new one.</value>
  </data>
  <data name="Main_NoPermissionsOrMissingDirectory" xml:space="preserve">
    <value>The output directory you have chosen either does not exist, or you do not have permissions to write files to it.</value>
  </data>
  <data name="DirectoryUtils_CreateFolder" xml:space="preserve">
    <value>Create Folder?</value>
  </data>
  <data name="DirectoryUtils_CreateFolderMsg" xml:space="preserve">
    <value>The folder you are trying to write to does not exist. Would you like HandBrake to create the following folder?
{0}</value>
  </data>
  <data name="MainViewModel_UnableToLaunchDestDir" xml:space="preserve">
    <value>Unable to launch destination directory.</value>
  </data>
  <data name="MainViewModel_UnableToLaunchDestDirSolution" xml:space="preserve">
    <value>Please check that you have a valid destination directory.</value>
  </data>
</root>