summaryrefslogtreecommitdiffstats
path: root/src/glx/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2013-02-17 13:53:19 -0800
committerIan Romanick <[email protected]>2013-11-07 18:12:33 -0800
commit0cce5538673148ffcd7aa9479f6b88cf9a641352 (patch)
tree568867a00ed6b47da0611d7594c64d1f8a5b90aa /src/glx/tests/Makefile.am
parentd4cc1869374c93ef82db5298e9a3941c69e61831 (diff)
glx/tests: Add unit tests for the GLX part of GLX_MESA_query_renderer
These tests primarilly ensure that the functions added by this extension don't abuse other interfaces (e.g., glx_screen::query_renderer_integer) when provided bad data. These tests helped me find a couple small bugs in the initial implementation. Signed-off-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/glx/tests/Makefile.am')
-rw-r--r--src/glx/tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/glx/tests/Makefile.am b/src/glx/tests/Makefile.am
index d940712a6c5..6995d987d35 100644
--- a/src/glx/tests/Makefile.am
+++ b/src/glx/tests/Makefile.am
@@ -16,7 +16,8 @@ glx_test_SOURCES = \
create_context_unittest.cpp \
enum_sizes.cpp \
fake_glx_screen.cpp \
- indirect_api.cpp
+ indirect_api.cpp \
+ query_renderer_unittest.cpp
glx_test_LDADD = \
$(top_builddir)/src/glx/libglx.la \