summaryrefslogtreecommitdiffstats
path: root/src/glx/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-11-16 11:15:37 +0000
committerEmil Velikov <[email protected]>2018-11-20 11:13:20 +0000
commit5bc509363b6dbc42af72668fe500b6aec988dbf0 (patch)
treed9bf7beec454f84cbc96e3892d640aebba776f7e /src/glx/meson.build
parent84445a86d192c0d7f07bc25a84080458de764149 (diff)
glx: make xf86vidmode mandatory for direct rendering
Currently we detect the module and if missing, the glXGetMsc* API is effectively a stub, always returning false. This is what effectively has been happening with our meson build :-( Thus users have no chance of using it - they cannot even distinguish if the failure is due to a misconfigured build. There's no reason for keeping xf86vidmode optional - it has been available in all distributions for years. Cc: [email protected] Signed-off-by: Emil Velikov <[email protected]> Acked-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Fixes: a47c525f3281a2753180e "meson: build glx"
Diffstat (limited to 'src/glx/meson.build')
-rw-r--r--src/glx/meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/glx/meson.build b/src/glx/meson.build
index 1de35fca6bc..3fd74439b11 100644
--- a/src/glx/meson.build
+++ b/src/glx/meson.build
@@ -136,10 +136,6 @@ gl_lib_cargs = [
'-D_REENTRANT',
]
-if dep_xxf86vm.found()
- gl_lib_cargs += '-DHAVE_XF86VIDMODE'
-endif
-
libglx = static_library(
'glx',
[files_libglx, glx_generated],
@@ -166,7 +162,7 @@ if with_glx == 'dri'
link_args : [ld_args_bsymbolic, ld_args_gc_sections, extra_ld_args_libgl],
dependencies : [
dep_libdrm, dep_dl, dep_m, dep_thread, dep_x11, dep_xcb_glx, dep_xcb,
- dep_x11_xcb, dep_xcb_dri2, dep_xext, dep_xfixes, dep_xdamage,
+ dep_x11_xcb, dep_xcb_dri2, dep_xext, dep_xfixes, dep_xdamage, dep_xxf86vm,
extra_deps_libgl,
],
version : gl_lib_version,