summaryrefslogtreecommitdiffstats
path: root/src/glx/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2017-12-02 17:13:39 +0000
committerJon Turney <[email protected]>2018-02-05 19:40:43 +0000
commitea8730024ff29f76c27e90746a786298785927e2 (patch)
tree4b210d4a4ad9f3fabf6c99325969f85a3a79ede5 /src/glx/meson.build
parent569628dd24f85ebddf263b6d974f0bc07c0e46dc (diff)
meson: build src/glx/apple
Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/glx/meson.build')
-rw-r--r--src/glx/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/glx/meson.build b/src/glx/meson.build
index 82141d3d4e5..7ac46ac0662 100644
--- a/src/glx/meson.build
+++ b/src/glx/meson.build
@@ -18,6 +18,9 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
+inc_glx = include_directories('.')
+
+subdir('apple')
if with_dri_platform == 'windows'
subdir('windows')
endif
@@ -100,6 +103,7 @@ endif
if with_dri_platform == 'apple'
files_libglx += files('applegl_glx.c')
+ extra_libs_libglx += libappleglx
elif with_dri_platform == 'windows'
files_libglx += files('driwindows_glx.c')
extra_libs_libglx += [