summaryrefslogtreecommitdiffstats
path: root/src/glx/SConscript
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-01-24 11:34:42 -0500
committerMatt Turner <[email protected]>2012-01-24 11:34:42 -0500
commit027ce0c493a85c863df88b43f61aea34bcd4cd58 (patch)
treef845bb4ce46ffe9dfa3e77ed88f51d4e354ade96 /src/glx/SConscript
parenta208468e04353239f2876cc2013f860b48a4f1c1 (diff)
Revert "Always build shared glapi"
This reverts commit adefee50d954151f76150af80207081ae3c247d9. Shared glapi was never tested with --enable-xlib-glx and turns out to cause a lot of problems. Conflicts: configure.ac
Diffstat (limited to 'src/glx/SConscript')
-rw-r--r--src/glx/SConscript3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/glx/SConscript b/src/glx/SConscript
index d08ae9e2c50..17a5690ee86 100644
--- a/src/glx/SConscript
+++ b/src/glx/SConscript
@@ -31,6 +31,9 @@ if env['HAVE_XF86VIDMODE']:
env.Append(CPPDEFINES = ['XF86VIDMODE'])
env.PkgUseModules('XF86VIDMODE')
+if False: # XXX: SHARED_GLAPI
+ env.Append(CPPDEFINES = ['GLX_SHARED_GLAPI'])
+
sources = [
'clientattrib.c',
'clientinfo.c',