summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorKyle Brenneman <[email protected]>2016-05-11 14:01:53 -0400
committerEmil Velikov <[email protected]>2016-05-30 16:29:49 +0100
commit22a9e00aab66d3dd6890e9eaac3f429c0ddec17e (patch)
treecd4568b2381dd25cfa611bc6bc676016d89b6f2f /src/glx/Makefile.am
parentcee459d84de7533d0e0a74a37f7fc4c0f2b77bcf (diff)
glx: Implement the libglvnd interface.
With reference to the libglvnd branch: https://cgit.freedesktop.org/mesa/mesa/log/?h=libglvnd This is a squashed commit containing all of Kyle's commits, all but two of Emil's commits (to follow), and a small fixup from myself to mark the rest of the glX* functions as _GLX_PUBLIC so they are not exported when building for libglvnd. I (ajax) squashed them together both for ease of review, and because most of the changes are un-useful intermediate states representing the evolution of glvnd's internal API. Co-author: Emil Velikov <[email protected]> Reviewed-by: Adam Jackson <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index d65fb816256..5154a23ae06 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -46,7 +46,6 @@ AM_CFLAGS = \
$(EXTRA_DEFINES_XF86VIDMODE) \
-D_REENTRANT \
-DDEFAULT_DRIVER_DIR=\"$(DRI_DRIVER_SEARCH_DIR)\" \
- -DGL_LIB_NAME=\"lib@[email protected]\" \
$(DEFINES) \
$(LIBDRM_CFLAGS) \
$(DRI2PROTO_CFLAGS) \
@@ -146,6 +145,22 @@ SUBDIRS += apple
libglx_la_LIBADD += $(builddir)/apple/libappleglx.la
endif
+if USE_LIBGLVND_GLX
+AM_CFLAGS += \
+ -DGL_LIB_NAME=\"lib@[email protected]\" \
+ $(GLVND_CFLAGS)
+
+libglx_la_SOURCES += \
+ glxglvnd.c \
+ g_glxglvnddispatchfuncs.c
+
+GL_LIB_VERSION=0
+else
+AM_CFLAGS += \
+ -DGL_LIB_NAME=\"lib@[email protected]\"
+GL_LIB_VERSION=1:2
+endif
+
GL_LIBS = \
libglx.la \
$(top_builddir)/src/mapi/glapi/libglapi.la \
@@ -154,7 +169,7 @@ GL_LIBS = \
GL_LDFLAGS = \
-no-undefined \
- -version-number 1:2 \
+ -version-number $(GL_LIB_VERSION) \
$(BSYMBOLIC) \
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)