summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <[email protected]>2014-01-29 11:40:25 -0800
committerKristian Høgsberg <[email protected]>2014-01-29 12:58:13 -0800
commitcbecd958a7e36736a4447ebe65e5017e5c0ea4a0 (patch)
treef826f9f122063736ae1f1524a74f6796f451ae38 /src/glx/Makefile.am
parent7965908976cdd1476db0ee7258d182292f975800 (diff)
build: Share the all-local rule for linking libraries into the build dir
This consolidates how we link the libraries into the build directory. It works for lib_LTLIBRARIES but not custom shared libraries like DRI drivers or gallium state trackers which needs special casing (cf dri mega drivers, for example) Signed-off-by: Kristian Høgsberg <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 54a0cc027da..c8dfb8651b6 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -118,9 +118,4 @@ lib@GL_LIB@_la_SOURCES =
lib@GL_LIB@_la_LIBADD = $(GL_LIBS)
lib@GL_LIB@_la_LDFLAGS = $(GL_LDFLAGS)
-# Provide compatibility with scripts for the old Mesa build system for
-# a while by putting a link to the driver into /lib of the build tree.
-all-local: lib@[email protected]
- $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
- ln -f .libs/lib@[email protected] $(top_builddir)/$(LIB_DIR)/lib@[email protected]
- ln -sf lib@[email protected] $(top_builddir)/$(LIB_DIR)/lib@[email protected]
+include $(top_srcdir)/install-lib-links.mk