summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2014-05-12 10:47:07 +0100
committerJon TURNEY <[email protected]>2014-05-23 15:24:07 +0100
commit5a459a036e33683410bab4df431ed553bd0eeb66 (patch)
treef45ad877571c64d1163ba4c8afb5038eb75d32d1 /src/glx/Makefile.am
parent45f9aae004f7bd723c3f313ee3dd8a25aa420ffa (diff)
Fix build of appleglx
Define GLX_USE_APPLEGL, as config/darwin used to, to turn on specific code to use the applegl direct renderer Convert src/glx/apple/Makefile to automake Since the applegl libGL is now built by linking libappleglx into libGL, rather than by linking selected files into a special libGL: - Remove duplicate code in apple/glxreply.c and apple/apple_glx.c. This makes apple/glxreply.c empty, so remove it - Some indirect rendering code is already guarded by !GLX_USE_APPLEGL, but we need to add those guards to indirect_glx.c, indirect_init.c (via it's generator), render2.c and vertarr.c so they don't generate anything Fix and update various includes glapi_gentable.c (which is only used on darwin), should be included in shared glapi as well, to provide _glapi_create_table_from_handle() Note that neither swrast nor indirect is supported in the APPLEGL path at the moment, which makes things more complex than they need to be. More untangling is needed to allow that v2: Correct apple/Makefile.am for srcdir != builddir Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Jeremy Huddleston Sequoia <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 4553de01a17..cdd898efc87 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -24,7 +24,7 @@ SHARED_GLAPI_CFLAGS = -DGLX_SHARED_GLAPI
SHARED_GLAPI_LIB = $(top_builddir)/src/mapi/shared-glapi/libglapi.la
endif
-SUBDIRS=. tests
+SUBDIRS =
if HAVE_XF86VIDMODE
EXTRA_DEFINES_XF86VIDMODE = -DXF86VIDMODE
@@ -86,6 +86,8 @@ libglx_la_SOURCES = \
glx_query.c \
glxhash.c
+libglx_la_LIBADD = $(top_builddir)/src/loader/libloader.la
+
if HAVE_DRISW
libglx_la_SOURCES += \
drisw_glx.c
@@ -114,9 +116,10 @@ endif
if HAVE_APPLEDRI
libglx_la_SOURCES += \
applegl_glx.c
-endif
-libglx_la_LIBADD = $(top_builddir)/src/loader/libloader.la
+SUBDIRS += apple
+libglx_la_LIBADD += $(builddir)/apple/libappleglx.la
+endif
GL_LIBS = \
libglx.la \
@@ -135,4 +138,6 @@ lib@GL_LIB@_la_SOURCES =
lib@GL_LIB@_la_LIBADD = $(GL_LIBS)
lib@GL_LIB@_la_LDFLAGS = $(GL_LDFLAGS)
+SUBDIRS += . tests
+
include $(top_srcdir)/install-lib-links.mk