summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorKyle Brenneman <[email protected]>2015-09-28 12:12:05 -0600
committerEmil Velikov <[email protected]>2015-10-02 13:25:05 +0100
commitd35391cfda13afdb19a47003af260e258575ef45 (patch)
tree4993d6496258da265de24564bf776283cfd33539 /src/glx/Makefile.am
parent798f260a2f553e339d7f5fc5120bb627893dc740 (diff)
glx: Don't hard-code the name "libGL.so.1" in driOpenDriver (v3)
Add a macro GL_LIB_NAME to hold the filename that configure comes up with based on the --with-gl-lib-name and --enable-mangling options. In driOpenDriver, use the GL_LIB_NAME macro instead of hard-coding "libGL.so.1". v2: Add an #ifndef/#define for GL_LIB_NAME so that non-autoconf builds will work. v3: Fix the library filename in the Makefile. Signed-off-by: Kyle Brenneman <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Cc: "10.6 11.0" <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 6e50e096fa2..e64955e3b3e 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -46,6 +46,7 @@ AM_CFLAGS = \
$(EXTRA_DEFINES_XF86VIDMODE) \
-D_REENTRANT \
-DDEFAULT_DRIVER_DIR=\"$(DRI_DRIVER_SEARCH_DIR)\" \
+ -DGL_LIB_NAME=\"lib@[email protected]\" \
$(DEFINES) \
$(LIBDRM_CFLAGS) \
$(DRI2PROTO_CFLAGS) \