summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-08-04 17:49:08 +0100
committerEmil Velikov <[email protected]>2017-08-04 23:54:52 +0100
commit10e7c2c64d46da38d30d04a2c10c8c3cd5a30f7a (patch)
tree167cd089b54a9cd6040c19273ecd4619291c78a1 /src/glx/Makefile.am
parent6c530ad1160518d9f035da4aba5a9d4df7369972 (diff)
loader: rework xmlconfig dependency
Currently xmlconfig is conditionally used, only when --enable-dri is available. As the library has moved to src/util and has wider wisebase, this guard is no longer correct. Strictly speaking - it wasn't since the introduction of xmlconfig into st/nine a while ago. Unconditionally enable xmlconfig and drop the linking. As said before there's other users of the library, so depending on the configure options we will get multiple definitions of said symbols. NOTE: To avoid breaking other combinations, this commit adds the xmlconfig link to the required places - throughout gallium and the DRI loaders. Cc: Aaron Watry <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Nicolai Hähnle <[email protected]> Tested-by: Dieter Nützel <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index b306bcc08db..34600475d98 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -97,7 +97,9 @@ libglx_la_SOURCES = \
singlepix.c \
vertarr.c
-libglx_la_LIBADD = $(top_builddir)/src/loader/libloader.la
+libglx_la_LIBADD = \
+ $(top_builddir)/src/loader/libloader.la \
+ $(top_builddir)/src/util/libxmlconfig.la
if HAVE_DRISW
libglx_la_SOURCES += \