summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorJohannes Obermayr <[email protected]>2012-03-03 18:11:22 +0100
committerEric Anholt <[email protected]>2012-03-07 09:37:46 -0800
commitd249bd9cbd38c8da5b3f11d3c50bdbfc612cf1e5 (patch)
tree79121169a75bf001f5f443a9d09689c0125f3389 /src/glx/Makefile.am
parentab6e081914ed2d9f8e166d6cfb9fd9998a45181d (diff)
glx: Also put a symlink from libGL.so in lib/ for now.
This fixes the libGLU.so.* build when a system libGL.so is not present since it is relying on the lib/ to build against until it gets converted to automake. Tested-by: Stéphane Marchesin <[email protected]> Reviewed-by: Stéphane Marchesin <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index b5bbebd9a57..79dc405372e 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -116,6 +116,7 @@ if !HAVE_MANGLED_GL
all-local: $(NORMAL_GL_LIB) $(MANGLED_GL_LIB)
$(MKDIR_P) $(top_builddir)/$(LIB_DIR);
ln -f .libs/libGL.so.1.2.0 $(top_builddir)/$(LIB_DIR)/libGL.so.1
+ ln -sf libGL.so.1 $(top_builddir)/$(LIB_DIR)/libGL.so
endif
$(GLAPI_LIB):