summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2014-01-23 10:21:09 -0800
committerEric Anholt <[email protected]>2014-01-27 09:37:10 -0800
commit7bd95ec437a5b1052fa17780a9d66677ec1fdc35 (patch)
treecc659c769fac23973a824df761852516f54f2807 /src/glx/Makefile.am
parentbe7a6976a8335a2e1a177769e96f7310ca6770d1 (diff)
dri2: Trust our own driver name lookup over the server's.
This allows Mesa to choose to rename driver .sos (or split drivers), without needing a flag day with the corresponding 2D driver. v2: Undo the loader-only-for-dri3 change. Reviewed-by: Keith Packard <[email protected]> [v1] Reviewed-by: Kristian Høgsberg <[email protected]> [v1]
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 69a6bf93da3..54a0cc027da 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -100,9 +100,9 @@ libglx_la_SOURCES = \
if HAVE_DRI3
libglx_la_SOURCES += \
dri3_glx.c
+endif
libglx_la_LIBADD = $(top_builddir)/src/loader/libloader.la
-endif
GL_LIBS = \
libglx.la \