summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-11-16 11:15:37 +0000
committerEmil Velikov <[email protected]>2018-11-20 11:13:20 +0000
commit5bc509363b6dbc42af72668fe500b6aec988dbf0 (patch)
treed9bf7beec454f84cbc96e3892d640aebba776f7e /src/glx/Makefile.am
parent84445a86d192c0d7f07bc25a84080458de764149 (diff)
glx: make xf86vidmode mandatory for direct rendering
Currently we detect the module and if missing, the glXGetMsc* API is effectively a stub, always returning false. This is what effectively has been happening with our meson build :-( Thus users have no chance of using it - they cannot even distinguish if the failure is due to a misconfigured build. There's no reason for keeping xf86vidmode optional - it has been available in all distributions for years. Cc: [email protected] Signed-off-by: Emil Velikov <[email protected]> Acked-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Fixes: a47c525f3281a2753180e "meson: build glx"
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index d208ce14bb7..a66957d609b 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -24,10 +24,6 @@ SUBDIRS =
EXTRA_DIST = SConscript meson.build
-if HAVE_XF86VIDMODE
-EXTRA_DEFINES_XF86VIDMODE = -DXF86VIDMODE
-endif
-
AM_CFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/GL/internal \
@@ -38,7 +34,6 @@ AM_CFLAGS = \
-I$(top_builddir)/src/mapi/glapi \
-I$(top_srcdir)/src/mapi/glapi \
$(VISIBILITY_CFLAGS) \
- $(EXTRA_DEFINES_XF86VIDMODE) \
-D_REENTRANT \
$(DEFINES) \
$(LIBDRM_CFLAGS) \