summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2014-12-06 22:57:47 -0800
committerMatt Turner <[email protected]>2014-12-12 12:11:48 -0800
commitd1c1d6d9b6c973e8353148712a3e3091a2cd01c6 (patch)
tree58614ee213a5bc27b904378cb1cd5b27d9b1f751 /src/glx/Makefile.am
parent82b7da3de7c78eceb35ba4f21b126d41963e67f8 (diff)
glx: Add headers to distribution.
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 94563d61deb..b0b309e733e 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -59,24 +59,34 @@ libglx_la_SOURCES = \
compsize.c \
create_context.c \
eval.c \
+ glxclient.h \
glxcmds.c \
glxconfig.c \
+ glxconfig.h \
glxcurrent.c \
glx_error.c \
+ glx_error.h \
glxext.c \
glxextensions.c \
+ glxextensions.h \
glxhash.c \
+ glxhash.h \
glx_pbuffer.c \
glx_query.c \
indirect.c \
indirect_glx.c \
indirect_init.c \
+ indirect_init.h \
indirect_size.c \
indirect_texture_compression.c \
indirect_transpose_matrix.c \
indirect_vertex_array.c \
+ indirect_vertex_array.h \
+ indirect_vertex_array_priv.h \
indirect_vertex_program.c \
indirect_window_pos.c \
+ packrender.h \
+ packsingle.h \
pixel.c \
pixelstore.c \
query_renderer.c \
@@ -90,12 +100,14 @@ libglx_la_LIBADD = $(top_builddir)/src/loader/libloader.la
if HAVE_DRISW
libglx_la_SOURCES += \
- drisw_glx.c
+ drisw_glx.c \
+ drisw_priv.h
endif
if HAVE_DRICOMMON
libglx_la_SOURCES += \
dri_common.c \
+ dri_common.h \
dri_common_query_renderer.c \
xfont.c
endif
@@ -104,13 +116,19 @@ if HAVE_DRI2
libglx_la_SOURCES += \
dri2.c \
dri2_glx.c \
+ dri2.h \
+ dri2_priv.h \
dri_glx.c \
- XF86dri.c
+ dri_sarea.h \
+ XF86dri.c \
+ xf86dri.h \
+ xf86dristr.h
endif
if HAVE_DRI3
libglx_la_SOURCES += \
- dri3_glx.c
+ dri3_glx.c \
+ dri3_priv.h
endif
if HAVE_APPLEDRI