aboutsummaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorArmin K <[email protected]>2013-11-09 00:06:45 +0100
committerMatt Turner <[email protected]>2013-11-09 09:12:46 -0800
commitf0f202e6b764be803470e27cba9102f14361ae22 (patch)
treef6364fa9dbdd97425a3ad155833c3360ccba151e /src/glx/Makefile.am
parent68349e52194b7eba521b88d42ee8db3bfdf0a877 (diff)
glx: conditionaly build dri3 and present loader (v3)
This patch makes it possible to disable DRI3 if desired. Tested with: ./configure --disable-dri3 --with-dri-drivers=i965 \ --with-gallium-drivers= --disable-vdpau --disable-egl \ --disable-gbm --disable-xvmc Reviewed-by: Ian Romanick <[email protected]> Reviewed-by: Matt Turner <[email protected]> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=71397 Cc: 10.0 <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index ae296b92236..0aec2aa3daa 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -94,10 +94,14 @@ libglx_la_SOURCES = \
dri2_glx.c \
dri2.c \
dri2_query_renderer.c \
- dri3_glx.c \
- dri3_common.c \
applegl_glx.c
+if HAVE_DRI3
+libglx_la_SOURCES += \
+ dri3_glx.c \
+ dri3_common.c
+endif
+
GL_LIBS = \
libglx.la \
$(SHARED_GLAPI_LIBS) \