summaryrefslogtreecommitdiffstats
path: root/src/glsl/glcpp/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <[email protected]>2012-09-14 19:59:54 +1000
committerDave Airlie <[email protected]>2012-09-15 08:20:56 +1000
commit53d46bc787318ccf9911fdd1d5fe99ee4db7f41a (patch)
tree22965e44894214b283d7824d635094aa4f3da421 /src/glsl/glcpp/Makefile.am
parentcc943c8470b38a1f13d2493f293a153f75754caa (diff)
glcpp: fix abuse of yylex
So glcpp tried to workaround yylex its own way, but failed, do it properly. This fixes another crash found after fixing the first crash. this is a candidate for 9.0 and stable branches Reviewed-by: Kenneth Graunke <[email protected]> Signed-off-by: Dave Airlie <[email protected]>
Diffstat (limited to 'src/glsl/glcpp/Makefile.am')
-rw-r--r--src/glsl/glcpp/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/glsl/glcpp/Makefile.am b/src/glsl/glcpp/Makefile.am
index 7a95b6848b9..87affce1c18 100644
--- a/src/glsl/glcpp/Makefile.am
+++ b/src/glsl/glcpp/Makefile.am
@@ -31,7 +31,7 @@ AM_CFLAGS = \
$(LIBRARY_DEFINES) \
$(API_DEFINES)
-AM_YFLAGS = -v -d
+AM_YFLAGS = -v -d -p "glcpp_parser_"
AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
noinst_LTLIBRARIES = libglcpp.la