summaryrefslogtreecommitdiffstats
path: root/src/glsl/builtin_compiler/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-01-17 14:40:21 -0800
committerMatt Turner <[email protected]>2013-01-22 14:33:28 -0800
commit3791ce05eb3c169c55b1d6eb5e613684e2cec4df (patch)
tree6cb754425968a436bc703651e34a36d08d7f7a1e /src/glsl/builtin_compiler/Makefile.am
parentefd201caa5cbfaf10d0ecad219046a9fe3593c4b (diff)
builtin_compiler/build: Use generated parser files
... instead of generating them again. Tested-by: Andreas Boll <[email protected]>
Diffstat (limited to 'src/glsl/builtin_compiler/Makefile.am')
-rw-r--r--src/glsl/builtin_compiler/Makefile.am19
1 files changed, 4 insertions, 15 deletions
diff --git a/src/glsl/builtin_compiler/Makefile.am b/src/glsl/builtin_compiler/Makefile.am
index d27aca5550e..a0255560b03 100644
--- a/src/glsl/builtin_compiler/Makefile.am
+++ b/src/glsl/builtin_compiler/Makefile.am
@@ -40,19 +40,16 @@ AM_CFLAGS = \
AM_CXXFLAGS = $(AM_CFLAGS)
-AM_YFLAGS = -v -d -p "glcpp_parser_"
-AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
-
include ../Makefile.sources
noinst_PROGRAMS = builtin_compiler
builtin_compiler_SOURCES = \
- $(GLSL_SRCDIR)/glcpp/glcpp-lex.l \
- $(GLSL_SRCDIR)/glcpp/glcpp-parse.y \
+ $(GLSL_BUILDDIR)/glcpp/glcpp-lex.c \
+ $(GLSL_BUILDDIR)/glcpp/glcpp-parse.c \
$(LIBGLCPP_FILES) \
- $(GLSL_SRCDIR)/glsl_lexer.ll \
- $(GLSL_BUILDDIR)/glsl_parser.cc \
+ $(GLSL_BUILDDIR)/glsl_lexer.cpp \
+ $(GLSL_BUILDDIR)/glsl_parser.cpp \
$(LIBGLSL_FILES) \
$(LIBGLSL_CXX_FILES) \
$(top_srcdir)/src/mesa/main/hash_table.c \
@@ -60,11 +57,3 @@ builtin_compiler_SOURCES = \
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_COMPILER_CXX_FILES) \
builtin_stubs.cpp
-
-BUILT_SOURCES = \
- glcpp-lex.c \
- glcpp-parse.c \
- glcpp-parse.h \
- glsl_lexer.cc
-
-CLEANFILES = $(BUILT_SOURCES)