aboutsummaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-10-17 15:20:09 -0700
committerJordan Justen <[email protected]>2012-12-07 14:46:18 -0800
commit1ddc021b2a992a214a7668672d35a55c160f6a90 (patch)
tree19b3e4edcc5be22e010ceba05ced0bf5fdf1d779 /src/glsl/Makefile.am
parent59284bc44a3f30ec18192098a4e1e43b6c6d392a (diff)
mesa: Use the new hash table for the variable refcount visitor.
Reviewed-by: Jordan Justen <[email protected]> [[email protected]: open_hash_table => hash_table] Signed-off-by: Jordan Justen <[email protected]> Reviewed-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 2ba439c77cc..aff1559e0f1 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -49,6 +49,7 @@ libglsl_la_LIBADD = glcpp/libglcpp.la
libglsl_la_LDFLAGS =
glsl_compiler_SOURCES = \
+ $(top_srcdir)/src/mesa/main/hash_table.c \
$(top_srcdir)/src/mesa/program/prog_hash_table.c \
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_COMPILER_CXX_FILES)
@@ -56,6 +57,7 @@ glsl_compiler_SOURCES = \
glsl_compiler_LDADD = libglsl.la
glsl_test_SOURCES = \
+ $(top_srcdir)/src/mesa/main/hash_table.c \
$(top_srcdir)/src/mesa/program/prog_hash_table.c \
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_SRCDIR)/standalone_scaffolding.cpp \