summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2014-12-12 11:13:10 -0800
committerJason Ekstrand <[email protected]>2015-01-15 07:20:20 -0800
commitd5410bd8f65b8d0f845dc8beccd498b6fa098660 (patch)
tree4d944b67568f4e49e7c5e91f85ad057593321f11 /src/glsl/Makefile.am
parent0e145a951e64e0b955e8315e22edf9e2ab4581ec (diff)
nir: Add an algebraic optimization pass
This pass uses the previously built algebraic transformations framework and should act as an example for anyone else wanting to make an algebraic transformation pass for NIR. Reviewed-by: Matt Turner <[email protected]> Reviewed-by: Connor Abbott <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 7f625738858..b2b74a9258a 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -25,6 +25,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/mapi \
-I$(top_srcdir)/src/mesa/ \
-I$(top_srcdir)/src/glsl/glcpp \
+ -I$(top_srcdir)/src/glsl/nir \
-I$(top_srcdir)/src/gtest/include \
$(DEFINES)
AM_CFLAGS = $(VISIBILITY_CFLAGS)
@@ -205,7 +206,8 @@ BUILT_SOURCES = \
glsl_parser.cpp \
glsl_lexer.cpp \
glcpp/glcpp-parse.c \
- glcpp/glcpp-lex.c
+ glcpp/glcpp-lex.c \
+ nir/nir_opt_algebraic.c
CLEANFILES = \
glcpp/glcpp-parse.h \
glsl_parser.h \
@@ -217,3 +219,7 @@ clean-local:
dist-hook:
$(RM) glcpp/tests/*.out
$(RM) glcpp/tests/subtest*/*.out
+
+nir/nir_opt_algebraic.c: nir/nir_opt_algebraic.py nir/nir_algebraic.py
+ $(MKDIR_P) nir; \
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/nir/nir_opt_algebraic.py > $@