summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <[email protected]>2013-01-16 19:49:40 -0800
committerChad Versace <[email protected]>2013-01-24 21:24:07 -0800
commiteac030e38e3cdd4ed4534516e3d3a50c8a372719 (patch)
tree29b81f500914cd9371e10625809f4286048b6a96 /src/glsl/Makefile.am
parent1fafd008392d5240dc36d0c72978cef62e21b4b1 (diff)
mesa,glsl: Move round_to_even() from glsl to mesa/main (v2)
Move round_to_even's definition to mesa/main so that _mesa_float_to_half() can use it in order to eliminate rounding bias. In additon to moving the fuction definition, prefix its name with "_mesa", just as all other functions in mesa/main are prefixed. v2: Fix Android build. Reviewed-by: Ian Romanick <[email protected]> Signed-off-by: Chad Versace <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 058d8aed38d..d0e5cd1d05e 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -52,6 +52,7 @@ check_PROGRAMS = \
tests_uniform_initializer_test_SOURCES = \
$(top_srcdir)/src/mesa/main/hash_table.c \
+ $(top_srcdir)/src/mesa/main/imports.c \
$(top_srcdir)/src/mesa/program/prog_hash_table.c\
$(top_srcdir)/src/mesa/program/symbol_table.c \
tests/copy_constant_to_storage_tests.cpp \
@@ -100,6 +101,7 @@ endif
glsl_test_SOURCES = \
$(top_srcdir)/src/mesa/main/hash_table.c \
+ $(top_srcdir)/src/mesa/main/imports.c \
$(top_srcdir)/src/mesa/program/prog_hash_table.c \
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_SRCDIR)/standalone_scaffolding.cpp \