summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2015-10-10 14:13:50 -0400
committerRob Clark <[email protected]>2015-10-16 19:33:38 -0400
commita6a6a71092ba912803ae2b47eb56e3afdf36feb5 (patch)
tree8c9197acaccf7ddab702678690b4f1b77dc52f20 /src/glsl/Makefile.am
parentb9b40ef9b7644ea24768bc8b7464b1719efe99bf (diff)
glsl: (mostly) remove libglsl_util
Now that NIR does not depend on glsl, we can (mostly[*]) get rid of the libglsl_util hack. [*] glsl_compiler is the one remaining user of libglsl_util Reviewed-by: Jason Ekstrand <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 437c6a5fbcd..ebea816b96d 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -96,7 +96,6 @@ tests_general_ir_test_CFLAGS = \
tests_general_ir_test_LDADD = \
$(top_builddir)/src/gtest/libgtest.la \
$(top_builddir)/src/glsl/libglsl.la \
- $(top_builddir)/src/libglsl_util.la \
$(PTHREAD_LIBS)
tests_uniform_initializer_test_SOURCES = \
@@ -109,7 +108,6 @@ tests_uniform_initializer_test_CFLAGS = \
tests_uniform_initializer_test_LDADD = \
$(top_builddir)/src/gtest/libgtest.la \
$(top_builddir)/src/glsl/libglsl.la \
- $(top_builddir)/src/libglsl_util.la \
$(PTHREAD_LIBS)
tests_sampler_types_test_SOURCES = \
@@ -119,7 +117,6 @@ tests_sampler_types_test_CFLAGS = \
tests_sampler_types_test_LDADD = \
$(top_builddir)/src/gtest/libgtest.la \
$(top_builddir)/src/glsl/libglsl.la \
- $(top_builddir)/src/libglsl_util.la \
$(PTHREAD_LIBS)
libglcpp_la_LIBADD = \
@@ -134,7 +131,6 @@ glcpp_glcpp_SOURCES = \
glcpp/glcpp.c
glcpp_glcpp_LDADD = \
libglcpp.la \
- $(top_builddir)/src/libglsl_util.la \
-lm
libglsl_la_LIBADD = libglcpp.la
@@ -168,7 +164,6 @@ glsl_test_SOURCES = \
glsl_test_LDADD = \
libglsl.la \
- $(top_builddir)/src/libglsl_util.la \
$(PTHREAD_LIBS)
# We write our own rules for yacc and lex below. We'd rather use automake,
@@ -272,6 +267,5 @@ nir_tests_control_flow_tests_CFLAGS = \
nir_tests_control_flow_tests_LDADD = \
$(top_builddir)/src/gtest/libgtest.la \
$(top_builddir)/src/glsl/libnir.la \
- $(top_builddir)/src/libglsl_util.la \
$(top_builddir)/src/util/libmesautil.la \
$(PTHREAD_LIBS)