summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2013-09-09 09:58:08 -0500
committerIan Romanick <[email protected]>2013-10-07 09:59:23 -0700
commit75e9bd13c4f1ca23256713b8fd6002f0a4b01c0f (patch)
tree137b641056dd536127e3e63f43cb1334ab514bcd /src/glsl/Makefile.am
parent5d6b0e7f1b1d8eaaded76964989a7adf4ed71662 (diff)
glsl_compiler: Re-enable building glsl_compiler
This allows application developers to use Mesa's compiler as a standalone validator for their shaders. This is mostly a revert of commit 569f0e4. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 2e161b844b0..cbf253cb585 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -49,6 +49,8 @@ check_PROGRAMS = \
tests/sampler-types-test \
tests/uniform-initializer-test
+noinst_PROGRAMS = glsl_compiler
+
tests_uniform_initializer_test_SOURCES = \
$(top_srcdir)/src/mesa/main/hash_table.c \
$(top_srcdir)/src/mesa/main/imports.c \
@@ -99,6 +101,15 @@ libglsl_la_SOURCES = \
glsl_parser.cpp \
$(LIBGLSL_FILES)
+glsl_compiler_SOURCES = \
+ $(top_srcdir)/src/mesa/main/hash_table.c \
+ $(top_srcdir)/src/mesa/main/imports.c \
+ $(top_srcdir)/src/mesa/program/prog_hash_table.c \
+ $(top_srcdir)/src/mesa/program/symbol_table.c \
+ $(GLSL_COMPILER_CXX_FILES)
+
+glsl_compiler_LDADD = libglsl.la
+
glsl_test_SOURCES = \
$(top_srcdir)/src/mesa/main/hash_table.c \
$(top_srcdir)/src/mesa/main/imports.c \