summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2013-10-22 15:10:16 -0700
committerIan Romanick <[email protected]>2013-10-22 15:23:30 -0700
commit1eee0a9f016a1049869f4677f5919186ee3785a2 (patch)
treed6a7aae0ddc0498999bbba56d908b3e51b72aa8c /src/glsl/Makefile.am
parentcf8b14ce6dc8e6c741005fa76cfda046e1618ea4 (diff)
glsl/tests: Unit test vertex shader in / out with link_invalidate_variable_locations
Validates: - ir_variable::explicit_location should not be modified. - If ir_variable::explicit_location is not set, ir_variable::location, ir_variable::location_frac, and ir_variable::is_unmatched_generic_inout must be reset to 0. - If ir_variable::explicit_location is set, ir_variable::location should not be modified. ir_variable::location_frac, and ir_variable::is_unmatched_generic_inout must be reset to 0. Previous unit tests have shown that all non-generic inputs / outputs have explicit_location set. v2: Split the link_invalidate_variable_locations interface change out to a separate patch. Remove the vertex_in_builtin_without_explicit and vertex_out_builtin_without_explicit tests. There was a lot of good discussion about this on the mailing list to which I refer the interested reader. Both changes suggested by Paul. http://lists.freedesktop.org/archives/mesa-dev/2013-October/046652.html Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Paul Berry <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 80949fb2741..b9ed5b62b53 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -60,6 +60,7 @@ tests_general_ir_test_SOURCES = \
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_SRCDIR)/standalone_scaffolding.cpp \
tests/builtin_variable_test.cpp \
+ tests/invalidate_locations_test.cpp \
tests/general_ir_test.cpp
tests_general_ir_test_CFLAGS = \
$(PTHREAD_CFLAGS)