summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2013-10-03 15:05:44 -0700
committerIan Romanick <[email protected]>2013-10-22 15:23:30 -0700
commitd05202900bcbe2d0bb8dabcbb3048f3a31b82bbd (patch)
treea2c827d26ae4c540ce52c008f3cb81428e0d8421 /src/glsl/Makefile.am
parent78b70ceae1c0155b3f832cb052dfb6fff3530ff4 (diff)
glsl/tests: Verify vertex shader built-ins generated by _mesa_glsl_initialize_variables
Checks that the variables generated meet certain criteria. - Vertex shader inputs have an explicit location. - Vertex shader outputs have an explicit location. - Fragment shader-only varying locations are not used. - Vertex shader uniforms and system values don't have an explicit location. - Vertex shader constants don't have an explicit location and are read-only. - No other kinds of vertex variables exist. It does not verify that an specific variables exist. v2: Fix memory management mistakes in common_builtin::string_starts_with_prefix. Clean up error message reporting in common_builtin::no_invalid_variable_modes. Both suggested by Paul. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Paul Berry <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index f43f49d67c1..80949fb2741 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -59,6 +59,7 @@ tests_general_ir_test_SOURCES = \
$(top_srcdir)/src/mesa/program/prog_hash_table.c\
$(top_srcdir)/src/mesa/program/symbol_table.c \
$(GLSL_SRCDIR)/standalone_scaffolding.cpp \
+ tests/builtin_variable_test.cpp \
tests/general_ir_test.cpp
tests_general_ir_test_CFLAGS = \
$(PTHREAD_CFLAGS)