summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-01-18 10:47:13 +0200
committerEmil Velikov <[email protected]>2016-01-26 16:08:20 +0000
commit1a882fd2ee84ae28a06cf07902dc4645d8ad4a6d (patch)
treedc85ad30ac20db8eecc658e7efcb3b0d7de898af /src/glsl/Makefile.am
parent2f86383091bde24a2a0b90a43c11a13165f8c397 (diff)
nir: move shader_enums.[ch] to compiler
This way one can reuse it in glsl, nir or other infrastructure without pulling nir as dependency. Signed-off-by: Emil Velikov <[email protected]> Acked-by: Matt Turner <[email protected]> Acked-by: Jose Fonseca <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index ba7af7c779d..07d5267df5a 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -137,7 +137,10 @@ glcpp_glcpp_LDADD = \
$(top_builddir)/src/libglsl_util.la \
-lm
-libglsl_la_LIBADD = libglcpp.la
+libglsl_la_LIBADD = \
+ $(top_builddir)/src/compiler/libcompiler.la \
+ libglcpp.la
+
libglsl_la_SOURCES = \
glsl_lexer.cpp \
glsl_parser.cpp \
@@ -147,6 +150,9 @@ libglsl_la_SOURCES = \
$(NIR_GENERATED_FILES) \
$(GLSL_TO_NIR_FILES)
+libnir_la_LIBADD = \
+ $(top_builddir)/src/compiler/libcompiler.la
+
libnir_la_SOURCES = \
$(NIR_FILES) \
$(NIR_GENERATED_FILES)